summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-05-12 17:40:44 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-05-12 17:40:44 +0000
commitfa2dd0cb77c04ac145be17ce01b13ef22bf9b5d5 (patch)
treebd697bb9ccee01bf82f4144096c3f3b4a0fef5bf /dev-util/codeblocks
parentupdate metadata (diff)
downloadgentoo-2-fa2dd0cb77c04ac145be17ce01b13ef22bf9b5d5.tar.gz
gentoo-2-fa2dd0cb77c04ac145be17ce01b13ef22bf9b5d5.tar.bz2
gentoo-2-fa2dd0cb77c04ac145be17ce01b13ef22bf9b5d5.zip
dev-util/codeblocks: Version bump (adding codeblocks-1.0_pre20070511)
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-util/codeblocks')
-rw-r--r--dev-util/codeblocks/ChangeLog8
-rw-r--r--dev-util/codeblocks/codeblocks-1.0_pre20070511.ebuild64
-rw-r--r--dev-util/codeblocks/files/digest-codeblocks-1.0_pre200705113
3 files changed, 74 insertions, 1 deletions
diff --git a/dev-util/codeblocks/ChangeLog b/dev-util/codeblocks/ChangeLog
index f2817e43cc2e..8ea5da4be63a 100644
--- a/dev-util/codeblocks/ChangeLog
+++ b/dev-util/codeblocks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/codeblocks
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/ChangeLog,v 1.5 2007/04/04 21:11:48 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/ChangeLog,v 1.6 2007/05/12 17:40:44 jurek Exp $
+
+*codeblocks-1.0_pre20070511 (12 May 2007)
+
+ 12 May 2007; Jurek Bartuszek <jurek@gentoo.org>
+ +codeblocks-1.0_pre20070511.ebuild:
+ Version bump
*codeblocks-1.0_pre20070404 (04 Apr 2007)
diff --git a/dev-util/codeblocks/codeblocks-1.0_pre20070511.ebuild b/dev-util/codeblocks/codeblocks-1.0_pre20070511.ebuild
new file mode 100644
index 000000000000..32bd1f298c7e
--- /dev/null
+++ b/dev-util/codeblocks/codeblocks-1.0_pre20070511.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/codeblocks-1.0_pre20070511.ebuild,v 1.1 2007/05/12 17:40:44 jurek Exp $
+
+#
+# WARNING:
+# If you are using gtk2.8 you need to upgrade to wxGTK-2.6.2
+#
+
+inherit eutils autotools wxwidgets
+
+#needed for wxwidgets.eclass
+WX_GTK_VER="2.6"
+
+DESCRIPTION="Code::Blocks - a free cross-platform C/C++ IDE"
+HOMEPAGE="http://www.codeblocks.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="unicode contrib debug"
+
+RDEPEND="=x11-libs/wxGTK-${WX_GTK_VER}*"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.5
+ >=sys-devel/automake-1.7
+ >=sys-devel/libtool-1.4"
+
+pkg_setup() {
+ if use unicode; then
+ #check for gtk2-unicode
+ need-wxwidgets unicode
+ else
+ #check for gtk2-ansi
+ need-wxwidgets gtk2
+ fi
+}
+
+src_compile() {
+ export WANT_AUTOCONF=2.5
+ export WANT_AUTOMAKE=1.7
+
+ local TMP
+
+ TMP="/usr/share/aclocal/libtool.m4"
+ einfo "Running ./bootstrap"
+ if [ -e "$TMP" ]; then
+ cp "$TMP" aclocal.m4 || die "cp failed"
+ fi
+ ./bootstrap || die "boostrap failed"
+
+ econf --with-wx-config="${WX_CONFIG}" \
+ $(use_enable contrib) \
+ $(use_enable debug) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+}
diff --git a/dev-util/codeblocks/files/digest-codeblocks-1.0_pre20070511 b/dev-util/codeblocks/files/digest-codeblocks-1.0_pre20070511
new file mode 100644
index 000000000000..616e83e412ed
--- /dev/null
+++ b/dev-util/codeblocks/files/digest-codeblocks-1.0_pre20070511
@@ -0,0 +1,3 @@
+MD5 bab5e813b14a036a0299b0246c4aa83a codeblocks-1.0_pre20070511.tar.bz2 8602420
+RMD160 c7c02bd94064c34874fcba4c6b809a4a52124c72 codeblocks-1.0_pre20070511.tar.bz2 8602420
+SHA256 db6e93992d0ce489b9f31d88eb72d4a253cc73ff59e1ea4da77afc26d10e5001 codeblocks-1.0_pre20070511.tar.bz2 8602420