summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-12-25 19:21:04 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-12-25 19:21:04 +0000
commit2dd623be9b5b74129e6b3911a5cac2f7ed0662cf (patch)
tree7284769db27526a2b6f0466f179d2a9b9b6f8067 /dev-util/cmake
parentremoved obsolete patches (diff)
downloadgentoo-2-2dd623be9b5b74129e6b3911a5cac2f7ed0662cf.tar.gz
gentoo-2-2dd623be9b5b74129e6b3911a5cac2f7ed0662cf.tar.bz2
gentoo-2-2dd623be9b5b74129e6b3911a5cac2f7ed0662cf.zip
Fix assembler test bug #338627. Thanks to Anthony (blueness) for the solution.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog7
-rw-r--r--dev-util/cmake/cmake-2.8.3-r1.ebuild3
-rw-r--r--dev-util/cmake/files/cmake-2.8.3-fix_assembler_test.patch17
3 files changed, 25 insertions, 2 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index c1a869e0290e..d3f117bfd5c1 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.148 2010/12/25 17:05:11 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.149 2010/12/25 19:21:04 scarabeus Exp $
+
+ 25 Dec 2010; Tomáš Chvátal <scarabeus@gentoo.org> cmake-2.8.3-r1.ebuild,
+ +files/cmake-2.8.3-fix_assembler_test.patch:
+ Fix assembler test bug #338627. Thanks to Anthony (blueness) for the
+ solution.
*cmake-2.8.3-r1 (25 Dec 2010)
diff --git a/dev-util/cmake/cmake-2.8.3-r1.ebuild b/dev-util/cmake/cmake-2.8.3-r1.ebuild
index 1325acbabe28..5b41b9d07205 100644
--- a/dev-util/cmake/cmake-2.8.3-r1.ebuild
+++ b/dev-util/cmake/cmake-2.8.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.3-r1.ebuild,v 1.1 2010/12/25 17:05:11 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.3-r1.ebuild,v 1.2 2010/12/25 19:21:04 scarabeus Exp $
EAPI="3"
@@ -57,6 +57,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.8.3-more-no_host_paths.patch
"${FILESDIR}"/${PN}-2.8.3-ruby_libname.patch
"${FILESDIR}"/${PN}-2.8.3-buffer_overflow.patch
+ "${FILESDIR}"/${PN}-2.8.3-fix_assembler_test.patch
)
_src_bootstrap() {
echo ${MAKEOPTS} | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' > /dev/null
diff --git a/dev-util/cmake/files/cmake-2.8.3-fix_assembler_test.patch b/dev-util/cmake/files/cmake-2.8.3-fix_assembler_test.patch
new file mode 100644
index 000000000000..0ea02b155278
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.3-fix_assembler_test.patch
@@ -0,0 +1,17 @@
+diff -urN cmake-2.8.3.orig/Tests/Assembler/CMakeLists.txt cmake-2.8.3/Tests/Assembler/CMakeLists.txt
+--- cmake-2.8.3.orig/Tests/Assembler/CMakeLists.txt 2010-12-25 16:56:42.646163500 +0100
++++ cmake-2.8.3/Tests/Assembler/CMakeLists.txt 2010-12-25 20:18:17.156163502 +0100
+@@ -11,8 +11,11 @@
+ enable_language(ASM-ATT OPTIONAL)
+ if(CMAKE_ASM-ATT_COMPILER_WORKS)
+ message(STATUS "Trying to enable ASM-ATT for Linux/x86 - succeeded")
+- # this assembler file was created using gcc -S main.c
+- set(SRCS main-linux-x86-gas.s)
++ # generate assembler file
++ execute_process(COMMAND ${CMAKE_C_COMPILER} -S
++ "${CMAKE_CURRENT_SOURCE_DIR}/main.c" -o
++ "${CMAKE_CURRENT_BINARY_DIR}/main-linux-x86-gas.s")
++ set(SRCS ${CMAKE_CURRENT_BINARY_DIR}/main-linux-x86-gas.s)
+ endif(CMAKE_ASM-ATT_COMPILER_WORKS)
+ endif(CMAKE_SYSTEM MATCHES Linux OR CMAKE_SYSTEM MATCHES FreeBSD)
+ endif(NOT SRCS AND CMAKE_SYSTEM_PROCESSOR MATCHES "[ix].?86$")