summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-18 11:27:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-18 11:27:27 +0000
commit5f33a5a670c23a1205875d81a20856d2c22cc970 (patch)
treeda7e9870830c04cd754696973b9171be3eb6ed7c /dev-util/bouml
parentSmall change for bug #147814 (diff)
downloadgentoo-2-5f33a5a670c23a1205875d81a20856d2c22cc970.tar.gz
gentoo-2-5f33a5a670c23a1205875d81a20856d2c22cc970.tar.bz2
gentoo-2-5f33a5a670c23a1205875d81a20856d2c22cc970.zip
Version bump.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'dev-util/bouml')
-rw-r--r--dev-util/bouml/ChangeLog7
-rw-r--r--dev-util/bouml/bouml-2.17.ebuild53
-rw-r--r--dev-util/bouml/files/digest-bouml-2.173
3 files changed, 62 insertions, 1 deletions
diff --git a/dev-util/bouml/ChangeLog b/dev-util/bouml/ChangeLog
index 2f8a9a40c42b..4a8f5c9ec887 100644
--- a/dev-util/bouml/ChangeLog
+++ b/dev-util/bouml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/bouml
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.2 2006/09/09 19:24:40 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.3 2006/09/18 11:27:27 flameeyes Exp $
+
+*bouml-2.17 (18 Sep 2006)
+
+ 18 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> +bouml-2.17.ebuild:
+ Version bump.
09 Sep 2006; <ticho@gentoo.org> bouml-2.16.ebuild:
Added ~x86 keyword. Closes bug #146827, reported by Sami Näätänen <sn.ml
diff --git a/dev-util/bouml/bouml-2.17.ebuild b/dev-util/bouml/bouml-2.17.ebuild
new file mode 100644
index 000000000000..d6f953825eff
--- /dev/null
+++ b/dev-util/bouml/bouml-2.17.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-2.17.ebuild,v 1.1 2006/09/18 11:27:27 flameeyes Exp $
+
+inherit qt3 toolchain-funcs multilib eutils
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Free UML 2 tool box with C++, Java and Idl code generation"
+HOMEPAGE="http://bouml.free.fr/"
+SRC_URI="http://bouml.free.fr/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="$(qt_min_version 3)"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e '/^MAKE/d' "${S}/Makefile"
+}
+
+src_compile() {
+ cd "${S}"
+ local sourcedirs=$(find . -name '*.pro' -not -name 'gpro.pro' -exec dirname {} \;)
+
+ for dir in ${sourcedirs}; do
+ pushd "${dir}"
+ "${QTDIR}/bin/qmake" QMAKE="${QTDIR}/bin/qmake"
+ emake \
+ CC="$(tc-getCC) ${CFLAGS}" \
+ CXX="$(tc-getCXX) ${CXXFLAGS}" \
+ LINK="$(tc-getCXX)" \
+ LFLAGS="${LDFLAGS}" || die "emake failed"
+ popd
+ done
+}
+
+src_install() {
+ # The provided wrapper is bogus, just install it in temporary directory and then remove it
+ emake BOUML_LIB="${D}/usr/$(get_libdir)/bouml" BOUML_DIR="${T}" install
+
+ # We fake the PATH change with LD_LIBRARY_PATH change, to follow the original wrapper
+ make_wrapper bouml "/usr/$(get_libdir)/bouml/bouml" . "/usr/$(get_libdir)/bouml"
+ sed -i -e 's:LD_LIBRARY_PATH:PATH:g' "${D}/usr/bin/bouml"
+
+ make_desktop_entry bouml "BOUML" bouml
+}
diff --git a/dev-util/bouml/files/digest-bouml-2.17 b/dev-util/bouml/files/digest-bouml-2.17
new file mode 100644
index 000000000000..d95b2cd206e5
--- /dev/null
+++ b/dev-util/bouml/files/digest-bouml-2.17
@@ -0,0 +1,3 @@
+MD5 512ecff8a092feee75fa87ce0bab83c9 bouml_2.17.tar.gz 2734026
+RMD160 254fcd59ba0ba8535b436d606856fe23813e8e00 bouml_2.17.tar.gz 2734026
+SHA256 6981f0b7c920d225e7d635995159f030120b5a7ed93e81b6d5241012828536d7 bouml_2.17.tar.gz 2734026