summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-03-03 12:32:09 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-03-03 12:32:09 +0000
commitafb5189fc9bb8106e37a8c48a1e26a05ebb24256 (patch)
tree7a3ab77abb7a2e040aa9b881347a9c28f874a501 /dev-util/boost-build
parentstable x86, bug 306333 (diff)
downloadgentoo-2-afb5189fc9bb8106e37a8c48a1e26a05ebb24256.tar.gz
gentoo-2-afb5189fc9bb8106e37a8c48a1e26a05ebb24256.tar.bz2
gentoo-2-afb5189fc9bb8106e37a8c48a1e26a05ebb24256.zip
Version bump dev-util/boost-build to 1.42.0.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/boost-build')
-rw-r--r--dev-util/boost-build/ChangeLog8
-rw-r--r--dev-util/boost-build/boost-build-1.42.0.ebuild111
-rw-r--r--dev-util/boost-build/files/boost-1.42-fix-mpich2-detection.patch35
3 files changed, 153 insertions, 1 deletions
diff --git a/dev-util/boost-build/ChangeLog b/dev-util/boost-build/ChangeLog
index 760f38cffdb5..1e71198256b5 100644
--- a/dev-util/boost-build/ChangeLog
+++ b/dev-util/boost-build/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/boost-build
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.48 2010/03/03 10:54:48 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/ChangeLog,v 1.49 2010/03/03 12:32:08 djc Exp $
+
+*boost-build-1.42.0 (03 Mar 2010)
+
+ 03 Mar 2010; Dirkjan Ochtman <djc@gentoo.org>
+ +files/boost-1.42-fix-mpich2-detection.patch, +boost-build-1.42.0.ebuild:
+ Version bump to dev-util/boost-build-1.42.0.
03 Mar 2010; Christian Faulhammer <fauli@gentoo.org>
boost-build-1.41.0.ebuild:
diff --git a/dev-util/boost-build/boost-build-1.42.0.ebuild b/dev-util/boost-build/boost-build-1.42.0.ebuild
new file mode 100644
index 000000000000..9524734a2318
--- /dev/null
+++ b/dev-util/boost-build/boost-build-1.42.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.42.0.ebuild,v 1.1 2010/03/03 12:32:08 djc Exp $
+
+EAPI="2"
+
+inherit flag-o-matic toolchain-funcs versionator
+
+MY_PV=$(replace_all_version_separators _)
+MAJOR_PV="$(replace_all_version_separators _ $(get_version_component_range 1-2))"
+
+DESCRIPTION="A system for large project software construction, which is simple to use and powerful."
+HOMEPAGE="http://www.boost.org/doc/tools/build/index.html"
+SRC_URI="mirror://sourceforge/boost/boost_${MY_PV}.tar.bz2"
+LICENSE="Boost-1.0"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="examples python"
+
+DEPEND="!<dev-libs/boost-1.34.0
+ !<=dev-util/boost-build-1.35.0-r1
+ python? ( dev-lang/python )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/boost_${MY_PV}/tools"
+
+pkg_setup() {
+ ewarn "Compilation of boost-build is known to break if {C,LD}FLAGS contain"
+ ewarn "extra white space (bug 293652)"
+}
+
+src_unpack() {
+ tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/{jam,build/v2} || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/boost-1.42-fix-mpich2-detection.patch"
+
+ # Remove stripping option
+ cd "${S}/jam/src"
+ sed -i -e 's|-s\b||' \
+ build.jam || die "sed failed"
+
+ # Force regeneration
+ rm jambase.c
+
+ # This patch allows us to fully control optimization
+ # and stripping flags when bjam is used as build-system
+ # We simply extend the optimization and debug-symbols feature
+ # with empty dummies called 'none'
+ cd "${S}/build/v2"
+ sed -i \
+ -e 's/\(off speed space\)/\1 none/' \
+ -e 's/\(debug-symbols : on off\)/\1 none/' \
+ tools/builtin.jam || die "sed failed"
+}
+
+src_compile() {
+ cd jam/src
+ local toolset
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ toolset=darwin
+ else
+ # Using boost's generic toolset here, which respects CC and CFLAGS
+ toolset=cc
+ fi
+
+ append-flags -fno-strict-aliasing
+
+ # For slotting
+ sed -i \
+ -e "s|/usr/share/boost-build|/usr/share/boost-build-${MAJOR_PV}|" \
+ Jambase || die "sed failed"
+
+ # The build.jam file for building bjam using a bootstrapped jam0 ignores
+ # the LDFLAGS env var (bug #209794). We have now two options:
+ # a) change the cc-target definition in build.jam to include separate compile
+ # and link targets to make it use the LDFLAGS var, or
+ # b) a simple dirty workaround by injecting the LDFLAGS in the LIBS env var
+ # (which should not be set by us).
+ if [[ -z "${LDFLAGS}" ]] ; then
+ CC=$(tc-getCC) ./build.sh ${toolset} $(use_with python) \
+ || die "building bjam failed"
+ else
+ LIBS=${LDFLAGS} CC=$(tc-getCC) ./build.sh ${toolset} \
+ $(use_with python) || die "building bjam failed"
+ fi
+}
+
+src_install() {
+ newbin jam/src/bin.*/bjam bjam-${MAJOR_PV}
+
+ cd "${S}/build/v2"
+ insinto /usr/share/boost-build-${MAJOR_PV}
+ doins -r boost-build.jam bootstrap.jam build-system.jam site-config.jam user-config.jam \
+ build kernel options tools util || die
+
+ dodoc changes.txt hacking.txt release_procedure.txt \
+ notes/build_dir_option.txt notes/relative_source_paths.txt
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r example
+ fi
+}
+
+src_test() {
+ cd jam/test
+ ./test.sh || die "tests failed"
+}
diff --git a/dev-util/boost-build/files/boost-1.42-fix-mpich2-detection.patch b/dev-util/boost-build/files/boost-1.42-fix-mpich2-detection.patch
new file mode 100644
index 000000000000..d3bd646a8ebb
--- /dev/null
+++ b/dev-util/boost-build/files/boost-1.42-fix-mpich2-detection.patch
@@ -0,0 +1,35 @@
+Index: tools/build/v2/tools/mpi.jam
+===================================================================
+--- tools/build/v2/tools/mpi.jam (revision 57744)
++++ tools/build/v2/tools/mpi.jam (working copy)
+@@ -156,14 +156,27 @@
+ # into a feature.
+ local match = [ MATCH "^(-.)(.*)" : $(cmdline) ] ;
+ local matched ;
+- if $(match) && $(match[2]) {
++ if $(match) && $(match[2]) {
+ local prefix = $(match[1]) ;
+ if $(feature_kinds$(prefix)) {
+ local name = $(feature_kinds$(prefix)) ;
+ local add = [ add_feature $(prefix) $(name) $(cmdline) ] ;
+
+ if $(add) {
+- result += $(add[1]) ;
++
++ if $(add[1]) = <find-shared-library>pthread
++ {
++ # Uhm. It's not really nice that this MPI implementation
++ # uses -lpthread as opposed to -pthread. We do want to
++ # set <threading>multi, instead of -lpthread.
++ result += "<threading>multi" ;
++ MPI_EXTRA_REQUIREMENTS += "<threading>multi" ;
++ }
++ else
++ {
++ result += $(add[1]) ;
++ }
++
+ cmdline = $(add[2]) ;
+ matched = yes ;
+ }
+