summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-01-14 08:47:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-01-14 08:47:02 +0000
commitc52b83d32e21bb06a46b8f8e07eac55981c47891 (patch)
tree758dc58a3a586abbd1961e281865349654dfe764 /dev-texlive/texlive-context
parentremove old (diff)
downloadgentoo-2-c52b83d32e21bb06a46b8f8e07eac55981c47891.tar.gz
gentoo-2-c52b83d32e21bb06a46b8f8e07eac55981c47891.tar.bz2
gentoo-2-c52b83d32e21bb06a46b8f8e07eac55981c47891.zip
Add a small hack to avoid file collisions
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-texlive/texlive-context')
-rw-r--r--dev-texlive/texlive-context/ChangeLog6
-rw-r--r--dev-texlive/texlive-context/texlive-context-2009.ebuild14
2 files changed, 18 insertions, 2 deletions
diff --git a/dev-texlive/texlive-context/ChangeLog b/dev-texlive/texlive-context/ChangeLog
index 1c1f3fcaf94a..06564c8a1dad 100644
--- a/dev-texlive/texlive-context/ChangeLog
+++ b/dev-texlive/texlive-context/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-texlive/texlive-context
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-texlive/texlive-context/ChangeLog,v 1.33 2010/01/11 03:06:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-texlive/texlive-context/ChangeLog,v 1.34 2010/01/14 08:47:02 aballier Exp $
+
+ 14 Jan 2010; Alexis Ballier <aballier@gentoo.org>
+ texlive-context-2009.ebuild:
+ Add a small hack to avoid file collisions
*texlive-context-2009 (11 Jan 2010)
diff --git a/dev-texlive/texlive-context/texlive-context-2009.ebuild b/dev-texlive/texlive-context/texlive-context-2009.ebuild
index e4aa42014939..09cb9e263a0a 100644
--- a/dev-texlive/texlive-context/texlive-context-2009.ebuild
+++ b/dev-texlive/texlive-context/texlive-context-2009.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-texlive/texlive-context/texlive-context-2009.ebuild,v 1.1 2010/01/11 03:06:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-texlive/texlive-context/texlive-context-2009.ebuild,v 1.2 2010/01/14 08:47:02 aballier Exp $
TEXLIVE_MODULE_CONTENTS="context jmn lmextra context-account context-algorithmic context-bnf context-chromato context-construction-plan context-degrade context-fixme context-french context-games context-gnuplot context-letter context-lettrine context-lilypond context-mathsets context-notes-zh-cn context-simplefonts context-simpleslides context-top-ten context-typearea context-typescripts context-vim collection-context
"
@@ -24,3 +24,15 @@ TEXLIVE_MODULE_BINSCRIPTS="texmf-dist/scripts/context/lua/luatools.lua texmf-dis
for i in ${TL_CONTEXT_UNIX_STUBS} ; do
TEXLIVE_MODULE_BINSCRIPTS="${TEXLIVE_MODULE_BINSCRIPTS} texmf-dist/scripts/context/stubs/unix/$i"
done
+
+# This small hack is needed in order to have a sane upgrade path:
+# the new TeX Live 2009 metapost produces this file but it is not recorded in
+# any package; when running fmtutil (like texmf-update does) this file will be
+# created and cause collisions.
+
+pkg_setup() {
+ if [ -f "${ROOT}/var/lib/texmf/web2c/metapost/metafun.log" ]; then
+ einfo "Removing ${ROOT}/var/lib/texmf/web2c/metapost/metafun.log"
+ rm -f "${ROOT}/var/lib/texmf/web2c/metapost/metafun.log"
+ fi
+}