summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-12-04 10:43:41 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-12-04 10:43:41 +0000
commitfcae7d9d58414e77f36c5015bdff35dd653e7922 (patch)
tree8c8f320b400212fde4fa7a0436cc165cae07fca1 /dev-tex
parentAdd ~arm keyword wrt bug #531274 (diff)
downloadgentoo-2-fcae7d9d58414e77f36c5015bdff35dd653e7922.tar.gz
gentoo-2-fcae7d9d58414e77f36c5015bdff35dd653e7922.tar.bz2
gentoo-2-fcae7d9d58414e77f36c5015bdff35dd653e7922.zip
version bump, bug #528746 by José Romildo Malaquias
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/dot2tex/ChangeLog9
-rw-r--r--dev-tex/dot2tex/dot2tex-2.9.0.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/dev-tex/dot2tex/ChangeLog b/dev-tex/dot2tex/ChangeLog
index bc4894ef0d7a..a16843bd4dca 100644
--- a/dev-tex/dot2tex/ChangeLog
+++ b/dev-tex/dot2tex/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/dot2tex
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/dot2tex/ChangeLog,v 1.34 2013/09/13 05:14:21 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/dot2tex/ChangeLog,v 1.35 2014/12/04 10:43:41 aballier Exp $
+
+*dot2tex-2.9.0 (04 Dec 2014)
+
+ 04 Dec 2014; Alexis Ballier <aballier@gentoo.org> +dot2tex-2.9.0.ebuild:
+ version bump, bug #528746 by José Romildo Malaquias
13 Sep 2013; Patrick Lauer <patrick@gentoo.org> dot2tex-2.8.7-r1.ebuild:
Drop pypy as pyparsing has changed
diff --git a/dev-tex/dot2tex/dot2tex-2.9.0.ebuild b/dev-tex/dot2tex/dot2tex-2.9.0.ebuild
new file mode 100644
index 000000000000..2cc0120efa53
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.9.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/dot2tex/dot2tex-2.9.0.ebuild,v 1.1 2014/12/04 10:43:41 aballier Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Graphviz to LaTeX converter"
+HOMEPAGE="https://dot2tex.readthedocs.org/ https://github.com/kjellmf/dot2tex"
+SRC_URI="https://github.com/kjellmf/dot2tex/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="doc examples"
+
+DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND="
+ media-gfx/pydot[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+DEPEND="${DEPEND}
+ dev-python/sphinx"
+
+python_compile_all() {
+ if use doc ; then
+ cd "${S}/docs"
+ emake html
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dohtml -r docs/_build/html/*
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}