summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2015-01-15 16:16:46 +0000
committerDenis Dupeyron <calchan@gentoo.org>2015-01-15 16:16:46 +0000
commitb036cdb06995b91b83d29cb1c31a65d5b083b30c (patch)
treed43901e6064dcaf3edb0c042f585968955e11b32 /dev-tex
parentAdd minimal useflag for coninstability of kde-plasma/polkit-kde-agent. (diff)
downloadgentoo-2-b036cdb06995b91b83d29cb1c31a65d5b083b30c.tar.gz
gentoo-2-b036cdb06995b91b83d29cb1c31a65d5b083b30c.tar.bz2
gentoo-2-b036cdb06995b91b83d29cb1c31a65d5b083b30c.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/circuit_macros/ChangeLog9
-rw-r--r--dev-tex/circuit_macros/circuit_macros-8.0.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-tex/circuit_macros/ChangeLog b/dev-tex/circuit_macros/ChangeLog
index cac3064f2c26..b820296ad2f0 100644
--- a/dev-tex/circuit_macros/ChangeLog
+++ b/dev-tex/circuit_macros/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/circuit_macros
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/circuit_macros/ChangeLog,v 1.14 2014/09/29 21:40:57 calchan Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/circuit_macros/ChangeLog,v 1.15 2015/01/15 16:16:46 calchan Exp $
+
+*circuit_macros-8.0 (15 Jan 2015)
+
+ 15 Jan 2015; Denis Dupeyron <calchan@gentoo.org> +circuit_macros-8.0.ebuild:
+ Version bump.
*circuit_macros-7.9.6 (29 Sep 2014)
diff --git a/dev-tex/circuit_macros/circuit_macros-8.0.ebuild b/dev-tex/circuit_macros/circuit_macros-8.0.ebuild
new file mode 100644
index 000000000000..ee5dc07b8b95
--- /dev/null
+++ b/dev-tex/circuit_macros/circuit_macros-8.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/circuit_macros/circuit_macros-8.0.ebuild,v 1.1 2015/01/15 16:16:46 calchan Exp $
+
+EAPI=5
+
+inherit texlive-common
+
+DESCRIPTION="M4 Macros for Electric circuit diagrams in TeX or LaTeX"
+HOMEPAGE="https://ece.uwaterloo.ca/~aplevich/Circuit_macros/"
+SRC_URI="https://ece.uwaterloo.ca/~aplevich/Circuit_macros/Circuit_macros.tar.gz -> circuit_macros-${PV}.tar.gz"
+
+LICENSE="LPPL-1.3c"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +script"
+
+DEPEND=""
+RDEPEND="|| ( app-text/texlive[graphics] app-text/texlive[pstricks] )
+ media-gfx/dpic
+ sys-devel/m4
+ script? ( app-text/texlive[graphics]
+ dev-texlive/texlive-latexextra )"
+
+S="${WORKDIR}/Circuit_macros${PV}"
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins *.m4
+ insinto /usr/share/texmf-site/tex/latex/${PN}
+ doins boxdims.sty
+ dodoc README CHANGES Makefile doc/CMman.pdf
+ rm -f doc/CMman.pdf
+ use doc && dodoc -r doc
+ use examples && dodoc -r examples
+ use script && dobin "${FILESDIR}/cm2pdf"
+ docompress -x \
+ /usr/share/doc/${PF}/Makefile \
+ /usr/share/doc/${PF}/doc \
+ /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ etexmf-update
+ use script && einfo "cm2pdf was installed to automatically create PDFs. Run cm2pdf --help for usage help."
+}
+
+pkg_postrm() {
+ etexmf-update
+}