summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-10-21 20:27:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-10-21 20:27:50 +0000
commit3dbd7d57e09c15f83c26d5ba905df98d0d7e48ff (patch)
tree1141bb960c7a116d5fa340a54d5430213e35c773 /dev-tex/lgrind
parentMarking xdg-user-dirs-0.13 ~ppc for bug 337632 (diff)
downloadgentoo-2-3dbd7d57e09c15f83c26d5ba905df98d0d7e48ff.tar.gz
gentoo-2-3dbd7d57e09c15f83c26d5ba905df98d0d7e48ff.tar.bz2
gentoo-2-3dbd7d57e09c15f83c26d5ba905df98d0d7e48ff.zip
Honour CC, LDFLAGS (bug #339749), CFLAGS, fix potential overflow (bug #339750)
(Portage version: 2.2_rc98/cvs/Linux x86_64)
Diffstat (limited to 'dev-tex/lgrind')
-rw-r--r--dev-tex/lgrind/ChangeLog11
-rw-r--r--dev-tex/lgrind/files/lgrind-3.67-fgets.patch13
-rw-r--r--dev-tex/lgrind/lgrind-3.67-r3.ebuild49
3 files changed, 71 insertions, 2 deletions
diff --git a/dev-tex/lgrind/ChangeLog b/dev-tex/lgrind/ChangeLog
index cc6a0af6041d..c5405953b759 100644
--- a/dev-tex/lgrind/ChangeLog
+++ b/dev-tex/lgrind/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-tex/lgrind
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/lgrind/ChangeLog,v 1.13 2007/04/28 16:19:32 tove Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/lgrind/ChangeLog,v 1.14 2010/10/21 20:27:50 aballier Exp $
+
+*lgrind-3.67-r3 (21 Oct 2010)
+
+ 21 Oct 2010; Alexis Ballier <aballier@gentoo.org> +lgrind-3.67-r3.ebuild,
+ +files/lgrind-3.67-fgets.patch:
+ Honour CC, LDFLAGS (bug #339749), CFLAGS, fix potential overflow (bug
+ #339750)
28 Apr 2007; Torsten Veller <tove@gentoo.org> lgrind-3.67-r2.ebuild:
Use doenvd (#173884)
diff --git a/dev-tex/lgrind/files/lgrind-3.67-fgets.patch b/dev-tex/lgrind/files/lgrind-3.67-fgets.patch
new file mode 100644
index 000000000000..5c8e802dc18a
--- /dev/null
+++ b/dev-tex/lgrind/files/lgrind-3.67-fgets.patch
@@ -0,0 +1,13 @@
+Index: lgrind/source/lgutil.c
+===================================================================
+--- lgrind.orig/source/lgutil.c
++++ lgrind/source/lgutil.c
+@@ -113,7 +113,7 @@ void Internal_Help_Language_List()
+ check=0;
+ if (*config=='\n' || config[strlen(config)-2]!='\\')
+ check=1;
+- if (fgets(config, BUFFERSIZE, tf)==NULL) break;
++ if (fgets(config, BUFFERSIZE/4, tf)==NULL) break;
+ if (check!=0) AddToLList(config, &currlch, &llch);
+ } while (strcmp((*currlch).name, "EndOfLanguageDefinitions")!=0);
+ rch=lch;
diff --git a/dev-tex/lgrind/lgrind-3.67-r3.ebuild b/dev-tex/lgrind/lgrind-3.67-r3.ebuild
new file mode 100644
index 000000000000..defca82b1504
--- /dev/null
+++ b/dev-tex/lgrind/lgrind-3.67-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/lgrind/lgrind-3.67-r3.ebuild,v 1.1 2010/10/21 20:27:50 aballier Exp $
+
+inherit latex-package toolchain-funcs eutils
+
+DESCRIPTION="A source pretty printer for LaTeX - styles to stylise your source and code examples."
+SRC_URI="mirror://gentoo/${PN}.tar.gz"
+LICENSE="as-is"
+
+IUSE="examples"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ echo 'CFLAGS+=-DDEFSFILE=\"$(DEFSFILE)\" -DVERSION=\"$(VERSION)\"' > source/Makefile
+ echo 'lgrind: lgrind.o lgrindef.o regexp.o' >> source/Makefile
+ epatch "${FILESDIR}/${P}-fgets.patch"
+}
+
+src_compile() {
+ tc-export CC
+
+ latex-package_src_compile
+ cd "${S}"/source
+ emake DEFSFILE="/usr/share/texmf/tex/latex/${PN}/lgrindef" VERSION="${PV}" || die
+}
+
+src_install() {
+ # binary first
+ dobin source/lgrind
+
+ # then the texmf stuff
+ latex-package_src_install
+ insinto /usr/share/texmf/tex/latex/${PN}
+ doins lgrindef
+
+ # and finally, the documentation
+ dodoc FAQ README
+ if use examples ; then
+ docinto examples
+ dodoc example/*
+ fi
+ cd "${S}"/source
+ doman lgrind.1 lgrindef.5
+}