summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-06-08 11:13:45 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-06-08 11:13:45 +0000
commitbdd160e30a341acfa2d6114b19a1c620f0cf7864 (patch)
tree5bb5e4df156a4dd039cae81d3a1b83f40b744bc0 /dev-tcltk/tclxml
parentStable for HPPA (bug #273093). (diff)
downloadgentoo-2-bdd160e30a341acfa2d6114b19a1c620f0cf7864.tar.gz
gentoo-2-bdd160e30a341acfa2d6114b19a1c620f0cf7864.tar.bz2
gentoo-2-bdd160e30a341acfa2d6114b19a1c620f0cf7864.zip
bump to version 3.2, bug 273112
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/tclxml')
-rw-r--r--dev-tcltk/tclxml/ChangeLog10
-rw-r--r--dev-tcltk/tclxml/files/tclxml-3.2-fix-implicit-declarations.patch12
-rw-r--r--dev-tcltk/tclxml/tclxml-3.2.ebuild67
3 files changed, 87 insertions, 2 deletions
diff --git a/dev-tcltk/tclxml/ChangeLog b/dev-tcltk/tclxml/ChangeLog
index 3353b40e5fb3..272ccf27afe0 100644
--- a/dev-tcltk/tclxml/ChangeLog
+++ b/dev-tcltk/tclxml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/tclxml
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/ChangeLog,v 1.31 2007/12/28 17:22:03 mr_bones_ Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/ChangeLog,v 1.32 2009/06/08 11:13:44 mescalinum Exp $
+
+*tclxml-3.2 (08 Jun 2009)
+
+ 08 Jun 2009; Federico Ferri <mescalinum@gentoo.org>
+ +files/tclxml-3.2-fix-implicit-declarations.patch, +tclxml-3.2.ebuild:
+ bump to version 3.2, bug 273112
28 Dec 2007; Michael Sterrett <mr_bones_@gentoo.org> +tclxml-2.4.ebuild:
resurrect tclxml-2.4.ebuild which is still in use
diff --git a/dev-tcltk/tclxml/files/tclxml-3.2-fix-implicit-declarations.patch b/dev-tcltk/tclxml/files/tclxml-3.2-fix-implicit-declarations.patch
new file mode 100644
index 000000000000..b463306abf1e
--- /dev/null
+++ b/dev-tcltk/tclxml/files/tclxml-3.2-fix-implicit-declarations.patch
@@ -0,0 +1,12 @@
+diff -urpN tclxml-3.2.orig/tclxml.c tclxml-3.2/tclxml.c
+--- tclxml-3.2.orig/tclxml.c 2009-06-08 12:56:10.000000000 +0200
++++ tclxml-3.2/tclxml.c 2009-06-08 12:57:24.000000000 +0200
+@@ -20,6 +20,8 @@
+ #include <tclxslt/tclxslt.h>
+ #include <string.h>
+
++int Tcldom_libxml2_Init ( Tcl_Interp *interp );
++
+ #define TCL_DOES_STUBS \
+ (TCL_MAJOR_VERSION > 8 || TCL_MAJOR_VERSION == 8 && (TCL_MINOR_VERSION > 1 || \
+ (TCL_MINOR_VERSION == 1 && TCL_RELEASE_LEVEL == TCL_FINAL_RELEASE)))
diff --git a/dev-tcltk/tclxml/tclxml-3.2.ebuild b/dev-tcltk/tclxml/tclxml-3.2.ebuild
new file mode 100644
index 000000000000..5903da0c7d6e
--- /dev/null
+++ b/dev-tcltk/tclxml/tclxml-3.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclxml/tclxml-3.2.ebuild,v 1.1 2009/06/08 11:13:44 mescalinum Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Pure Tcl implementation of an XML parser."
+HOMEPAGE="http://tclxml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tclxml/${P}.tar.gz"
+
+IUSE="expat threads xml"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/tcl-8.2
+ >=dev-tcltk/tcllib-1.2
+ xml? ( >=dev-libs/libxml2-2.6.9 )
+ expat? ( dev-libs/expat )
+ !dev-tcltk/tclxml-expat"
+# test? ( dev-tcltk/tclparser )
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ epatch "${FILESDIR}"/"${P}"-fix-implicit-declarations.patch
+}
+
+src_compile() {
+ local myconf=""
+
+ use threads && myconf="${myconf} --enable-threads"
+
+ econf ${myconf} || die
+ emake || die
+
+ if use xml ; then
+ cd "${S}"/libxml2
+ econf ${myconf} --with-Tclxml=.. || die
+ emake || die
+ fi
+ if use expat ; then
+ cd "${S}"/expat
+ econf ${myconf} --with-Tclxml=.. || die
+ emake || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use xml ; then
+ cd "${S}"/libxml2
+ emake DESTDIR="${D}" install || die
+ fi
+ if use expat ; then
+ cd "${S}"/expat
+ emake DESTDIR="${D}" install || die
+ fi
+
+ cd "${S}"
+ dodoc ANNOUNCE ChangeLog
+ dohtml doc/*.html
+}