summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-04 08:50:50 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-04 08:50:50 +0000
commit788eebfb05149d5a9ff5331c0143b148ca7726d9 (patch)
treefb868c5e713d6945ec0efd58efd10010cdb07db5 /dev-tcltk/expect
parentstable on x86 (diff)
downloadgentoo-2-788eebfb05149d5a9ff5331c0143b148ca7726d9.tar.gz
gentoo-2-788eebfb05149d5a9ff5331c0143b148ca7726d9.tar.bz2
gentoo-2-788eebfb05149d5a9ff5331c0143b148ca7726d9.zip
m68k love
(Portage version: 2.1.1_rc1-r3)
Diffstat (limited to 'dev-tcltk/expect')
-rw-r--r--dev-tcltk/expect/expect-5.42.1-r1.ebuild4
-rw-r--r--dev-tcltk/expect/expect-5.43.0.ebuild14
2 files changed, 9 insertions, 9 deletions
diff --git a/dev-tcltk/expect/expect-5.42.1-r1.ebuild b/dev-tcltk/expect/expect-5.42.1-r1.ebuild
index 89bd689d2eed..064913b819a8 100644
--- a/dev-tcltk/expect/expect-5.42.1-r1.ebuild
+++ b/dev-tcltk/expect/expect-5.42.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.42.1-r1.ebuild,v 1.7 2006/09/04 01:20:36 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.42.1-r1.ebuild,v 1.8 2006/09/04 08:50:50 vapier Exp $
inherit eutils gnuconfig
@@ -10,7 +10,7 @@ SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
IUSE="X doc"
# We need dejagnu for src_test, but dejagnu needs expect
diff --git a/dev-tcltk/expect/expect-5.43.0.ebuild b/dev-tcltk/expect/expect-5.43.0.ebuild
index 160540980c82..e0d6c38baf46 100644
--- a/dev-tcltk/expect/expect-5.43.0.ebuild
+++ b/dev-tcltk/expect/expect-5.43.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0.ebuild,v 1.2 2006/04/11 16:28:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0.ebuild,v 1.3 2006/09/04 08:50:50 vapier Exp $
inherit eutils gnuconfig
@@ -10,7 +10,7 @@ SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="X doc"
# We need dejagnu for src_test, but dejagnu needs expect
@@ -25,11 +25,11 @@ S=${WORKDIR}/${NON_MICRO_V}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-5.42.1-multilib.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-5.42.1-multilib.patch
# fix the rpath being set to /var/tmp/portage/...
- epatch ${FILESDIR}/${PN}-5.39.0-libdir.patch
+ epatch "${FILESDIR}"/${PN}-5.39.0-libdir.patch
sed -i 's#/usr/local/bin#/usr/bin#' expect.man
sed -i 's#/usr/local/bin#/usr/bin#' expectk.man
@@ -79,12 +79,12 @@ src_test() {
src_install() {
dodir /usr/$(get_libdir)
- make install INSTALL_ROOT=${D} || die "make install failed"
+ make install INSTALL_ROOT="${D}" || die "make install failed"
dodoc ChangeLog FAQ HISTORY NEWS README
local static_lib="lib${NON_MICRO_V/-/}.a"
- rm ${D}/usr/$(get_libdir)/${NON_MICRO_V/-/}/${static_lib}
+ rm "${D}"/usr/$(get_libdir)/${NON_MICRO_V/-/}/${static_lib}
#install examples if 'doc' is set
if use doc ; then