summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomás Touceda <chiiph@gentoo.org>2010-04-09 00:39:58 +0000
committerTomás Touceda <chiiph@gentoo.org>2010-04-09 00:39:58 +0000
commitc671f4bf87b1b9df2750cc464dbf46e8dcb9fcff (patch)
tree71b80db97ddb72b2f6c40948ceab6b6f7d7144ac /dev-scheme
parentApply patch to kdelibs to fix hang caused in dolphin when accessing network f... (diff)
downloadgentoo-2-c671f4bf87b1b9df2750cc464dbf46e8dcb9fcff.tar.gz
gentoo-2-c671f4bf87b1b9df2750cc464dbf46e8dcb9fcff.tar.bz2
gentoo-2-c671f4bf87b1b9df2750cc464dbf46e8dcb9fcff.zip
Version bump to latest upstream stable 2.0.1. Clean up hop-1.*. Added init.d/conf.d scripts.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/hop/ChangeLog12
-rw-r--r--dev-scheme/hop/files/hop.confd4
-rw-r--r--dev-scheme/hop/files/hop.initd45
-rw-r--r--dev-scheme/hop/hop-1.10.2.ebuild39
-rw-r--r--dev-scheme/hop/hop-1.11.0.ebuild39
-rw-r--r--dev-scheme/hop/hop-1.11.1.ebuild39
-rw-r--r--dev-scheme/hop/hop-2.0.1.ebuild47
-rw-r--r--dev-scheme/hop/metadata.xml5
8 files changed, 111 insertions, 119 deletions
diff --git a/dev-scheme/hop/ChangeLog b/dev-scheme/hop/ChangeLog
index 6b07f00accad..a4ed25453698 100644
--- a/dev-scheme/hop/ChangeLog
+++ b/dev-scheme/hop/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-scheme/hop
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/hop/ChangeLog,v 1.9 2009/07/13 14:45:58 hkbst Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/hop/ChangeLog,v 1.10 2010/04/09 00:39:57 chiiph Exp $
+
+*hop-2.0.1 (08 Apr 2010)
+
+ 08 Apr 2010; Tomas Touceda <chiiph@gentoo.org> -hop-1.10.2.ebuild, -hop-1.11.0.ebuild,
+ -hop-1.11.1.ebuild, +hop-2.0.1.ebuild, +files/hop.confd, +files/hop.initd,
+ metadata.xml:
+ Version bump to latest upstream stable 2.0.1. Clean up hop-1.*. Added
+ init.d/conf.d scripts.
*hop-1.11.1 (13 Jul 2009)
diff --git a/dev-scheme/hop/files/hop.confd b/dev-scheme/hop/files/hop.confd
new file mode 100644
index 000000000000..1688f64813d5
--- /dev/null
+++ b/dev-scheme/hop/files/hop.confd
@@ -0,0 +1,4 @@
+# /etc/conf.d/hop: config file for /etc/init.d/hop
+
+# see `hop --help` # for valid cmdline options
+#HOP_OPTS=""
diff --git a/dev-scheme/hop/files/hop.initd b/dev-scheme/hop/files/hop.initd
new file mode 100644
index 000000000000..85515e5ff91c
--- /dev/null
+++ b/dev-scheme/hop/files/hop.initd
@@ -0,0 +1,45 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/hop/files/hop.initd,v 1.1 2010/04/09 00:39:58 chiiph Exp $
+
+HOPEXEC=/usr/bin/hop
+HOPUSER=hop
+HOPHOME=/var/www
+PIDFILE=/var/run/hop.pid
+LOGFILE=/var/log/hop
+
+# For user extensions through /etc/conf.d/hop
+HOP_OPTS="--log-file ${LOGFILE} ${HOP_OPTS}"
+
+depend() {
+ need localmount net
+}
+
+logfile() {
+ if [ ! -f ${LOGFILE} ]
+ then
+ touch ${LOGFILE}
+ fi
+ chown ${HOPUSER} ${LOGFILE} || eerror "Cannot create logfile"
+ return 0
+}
+
+start() {
+ logfile || return 1
+
+ ebegin "Starting Hop Web Broker"
+ start-stop-daemon --start --oknodo \
+ --background --chuid ${HOPUSER} \
+ --make-pidfile --pidfile ${PIDFILE} \
+ --exec ${HOPEXEC} --env HOME=${HOPHOME} \
+ -- ${HOP_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Hop Web Broker"
+ start-stop-daemon --stop \
+ --exec ${HOPEXEC} --pidfile ${PIDFILE}
+ eend $?
+}
diff --git a/dev-scheme/hop/hop-1.10.2.ebuild b/dev-scheme/hop/hop-1.10.2.ebuild
deleted file mode 100644
index a7706bcd42c5..000000000000
--- a/dev-scheme/hop/hop-1.10.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/hop/hop-1.10.2.ebuild,v 1.1 2009/02/14 16:14:53 hkbst Exp $
-
-inherit multilib eutils
-
-MY_P=${P/_/-}
-
-DESCRIPTION="Hop is a higher-order language for programming interactive web applications such as web agendas, web galleries, music players, etc. that is implemented as a Web broker"
-HOMEPAGE="http://hop.inria.fr/"
-SRC_URI="ftp://ftp-sop.inria.fr/mimosa/fp/Hop/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND=">=dev-scheme/bigloo-3.1b"
-RDEPEND=""
-
-IUSE="ssl threads"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- enewgroup hop
- enewuser hop -1 -1 /var/www hop
-}
-
-src_compile() {
- # Hop doesn't use autoconf and consequently a lot of options used by econf give errors
- # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
- ./configure --prefix=/usr --libdir=/usr/$(get_libdir) --etcdir=/etc/${PN} $(use_enable ssl) $(use_enable threads) || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "install failed"
-}
diff --git a/dev-scheme/hop/hop-1.11.0.ebuild b/dev-scheme/hop/hop-1.11.0.ebuild
deleted file mode 100644
index 1ebfdd226039..000000000000
--- a/dev-scheme/hop/hop-1.11.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/hop/hop-1.11.0.ebuild,v 1.1 2009/06/24 15:23:28 hkbst Exp $
-
-inherit multilib eutils
-
-MY_P=${P/_/-}
-
-DESCRIPTION="Hop is a higher-order language for programming interactive web applications such as web agendas, web galleries, music players, etc. that is implemented as a Web broker"
-HOMEPAGE="http://hop.inria.fr/"
-SRC_URI="ftp://ftp-sop.inria.fr/mimosa/fp/Hop/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND=">=dev-scheme/bigloo-3.2b"
-RDEPEND=""
-
-IUSE="ssl threads"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- enewgroup hop
- enewuser hop -1 -1 /var/www hop
-}
-
-src_compile() {
- # Hop doesn't use autoconf and consequently a lot of options used by econf give errors
- # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
- ./configure --prefix=/usr --libdir=/usr/$(get_libdir) --etcdir=/etc/hop $(use_enable ssl) $(use_enable threads) || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "install failed"
-}
diff --git a/dev-scheme/hop/hop-1.11.1.ebuild b/dev-scheme/hop/hop-1.11.1.ebuild
deleted file mode 100644
index e231c0bd3f8e..000000000000
--- a/dev-scheme/hop/hop-1.11.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/hop/hop-1.11.1.ebuild,v 1.1 2009/07/13 14:45:58 hkbst Exp $
-
-inherit multilib eutils
-
-MY_P=${P/_/-}
-
-DESCRIPTION="Hop is a higher-order language for programming interactive web applications."
-HOMEPAGE="http://hop.inria.fr/"
-SRC_URI="ftp://ftp-sop.inria.fr/mimosa/fp/Hop/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND=">=dev-scheme/bigloo-3.2b"
-RDEPEND=""
-
-IUSE="ssl threads"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- enewgroup hop
- enewuser hop -1 -1 /var/www hop
-}
-
-src_compile() {
- # Hop doesn't use autoconf and consequently a lot of options used by econf give errors
- # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
- ./configure --prefix=/usr --mandir=/usr/share/man --libdir=/usr/$(get_libdir) --etcdir=/etc/hop $(use_enable ssl) $(use_enable threads) || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "install failed"
-}
diff --git a/dev-scheme/hop/hop-2.0.1.ebuild b/dev-scheme/hop/hop-2.0.1.ebuild
new file mode 100644
index 000000000000..04c61ebc543b
--- /dev/null
+++ b/dev-scheme/hop/hop-2.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/hop/hop-2.0.1.ebuild,v 1.1 2010/04/09 00:39:57 chiiph Exp $
+
+EAPI="2"
+
+inherit multilib eutils
+
+DESCRIPTION="Hop is a higher-order language for programming interactive web applications"
+HOMEPAGE="http://hop.inria.fr/"
+SRC_URI="ftp://ftp-sop.inria.fr/indes/fp/Hop/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-scheme/bigloo-3.3a[ssl?,threads?]"
+
+RDEPEND="${DEPEND}"
+
+IUSE="ssl threads debug"
+
+pkg_setup() {
+ enewgroup hop
+ enewuser hop -1 -1 /var/lib/hop hop
+}
+
+src_configure() {
+ # Hop doesn't use autoconf and consequently a lot of options used by econf give errors
+ # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --libdir=/usr/$(get_libdir) \
+ --etcdir=/etc/hop \
+ $(use_enable ssl) \
+ $(use_enable threads) \
+ $(use debug && echo "--debug") \
+ || die "configure failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ newinitd "${FILESDIR}/hop.initd" hop || die
+ newconfd "${FILESDIR}/hop.confd" hop || die
+}
diff --git a/dev-scheme/hop/metadata.xml b/dev-scheme/hop/metadata.xml
index 717534c90e08..a424df30ec6f 100644
--- a/dev-scheme/hop/metadata.xml
+++ b/dev-scheme/hop/metadata.xml
@@ -5,4 +5,9 @@
<longdescription lang="en">
HOP is a new programming language designed for the Web 2.0. It is a higher-order language for programming interactive web applications such as web agendas, web galleries, music players, etc. HOP can be viewed as a replacement for traditional graphical toolkits. HOP is implemented as a Web broker, i.e., a Web server that may act indifferently as a regular Web server or Web proxy.
</longdescription>
+ <use>
+ <flag name="ssl">Enable SSL support for hop</flag>
+ <flag name="threads">Enable thread support for hop, it depends on <pkg>dev-scheme/bigloo</pkg> built with threads use flag.</flag>
+ <flag name="debug">Enables building with debug symbols</flag>
+ </use>
</pkgmetadata>