summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-01-24 16:59:50 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-01-24 16:59:50 +0000
commit770a65ee1a744d03b8220b5a54329a0d2079e209 (patch)
treefbf7a81060ba04c5f442e2de5839985d76ea9215 /dev-scheme
parentRemoved unused versions. (diff)
downloadgentoo-2-770a65ee1a744d03b8220b5a54329a0d2079e209.tar.gz
gentoo-2-770a65ee1a744d03b8220b5a54329a0d2079e209.tar.bz2
gentoo-2-770a65ee1a744d03b8220b5a54329a0d2079e209.zip
revision bump 3.1.4 for moving its install destination around. Make install work with ROOT
(Portage version: 2.1.2-r2)
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/slib/ChangeLog8
-rw-r--r--dev-scheme/slib/files/digest-slib-3.1.4-r13
-rw-r--r--dev-scheme/slib/slib-3.1.4-r1.ebuild46
3 files changed, 56 insertions, 1 deletions
diff --git a/dev-scheme/slib/ChangeLog b/dev-scheme/slib/ChangeLog
index 54ae92c5925c..5a3ea4f37282 100644
--- a/dev-scheme/slib/ChangeLog
+++ b/dev-scheme/slib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/slib
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/slib/ChangeLog,v 1.13 2007/01/22 18:37:38 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/slib/ChangeLog,v 1.14 2007/01/24 16:59:50 hkbst Exp $
+
+*slib-3.1.4-r1 (24 Jan 2007)
+
+ 24 Jan 2007; Marijn Schouten <hkBst@gentoo.org> +slib-3.1.4-r1.ebuild:
+ revision bump 3.1.4 for moving its install destination around. Make install
+ work with ROOT
22 Jan 2007; Marijn Schouten <hkBst@gentoo.org> slib-3.1.4.ebuild:
put slib in /usr/share/ instead of /usr/lib/
diff --git a/dev-scheme/slib/files/digest-slib-3.1.4-r1 b/dev-scheme/slib/files/digest-slib-3.1.4-r1
new file mode 100644
index 000000000000..aba33066f8e0
--- /dev/null
+++ b/dev-scheme/slib/files/digest-slib-3.1.4-r1
@@ -0,0 +1,3 @@
+MD5 b0df4089264fd248c9c4f6d2e074b9f6 slib3a4.zip 994885
+RMD160 2cd478889d462994d62363379e17e74a28b4ef8c slib3a4.zip 994885
+SHA256 d66d642c060d08f16aaca19fd2fd3040de22404eace80a36802cfe39cb5fb9b2 slib3a4.zip 994885
diff --git a/dev-scheme/slib/slib-3.1.4-r1.ebuild b/dev-scheme/slib/slib-3.1.4-r1.ebuild
new file mode 100644
index 000000000000..5dad7c975e8d
--- /dev/null
+++ b/dev-scheme/slib/slib-3.1.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/slib/slib-3.1.4-r1.ebuild,v 1.1 2007/01/24 16:59:50 hkbst Exp $
+
+inherit versionator eutils
+
+#version magic thanks to masterdriverz and UberLord using bash array instead of tr
+trarr="0abcdefghi"
+MY_PV="$(get_version_component_range 1)${trarr:$(get_version_component_range 2):1}$(get_version_component_range 3)"
+
+MY_P=${PN}${MY_PV}
+S=${WORKDIR}/${PN}
+DESCRIPTION="library providing functions for Scheme implementations"
+SRC_URI="http://swiss.csail.mit.edu/ftpdir/scm/${MY_P}.zip"
+
+HOMEPAGE="http://swiss.csail.mit.edu/~jaffer/SLIB"
+
+SLOT="0"
+LICENSE="public-domain BSD"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+#unzip for unpacking
+#depend on guile for now, until slib actually works with another scheme implementation in portage
+RDEPEND="~dev-scheme/guile-1.6.8"
+DEPEND="app-arch/unzip
+ ${RDEPEND}"
+
+# slib tests rely on scm being installed. It isn't even in portage :(
+RESTRICT="test"
+
+# maybe also do "make infoz"
+
+src_install() {
+ insinto /usr/share/slib/ #don't install directly into guile dir
+ doins *.scm
+ doins *.init
+ dodoc ANNOUNCE ChangeLog FAQ README
+ doinfo slib.info
+ dosym /usr/share/slib/ /usr/share/guile/slib # link from guile dir
+}
+
+pkg_postinst() {
+ einfo "Installing slib for guile..."
+ ${ROOT}/usr/bin/guile -c "(use-modules (ice-9 slib)) (require 'new-catalog)"
+}