summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2008-10-12 16:42:03 +0000
committerMarijn Schouten <hkbst@gentoo.org>2008-10-12 16:42:03 +0000
commit8b0bba37c6d079309bea10c7875442fef9bf25ec (patch)
treea21bc5246ae8049754f0f7fc4be9f1d6e89aeee8 /dev-scheme/bigloo/bigloo-3.1b.ebuild
parentRemove livetest script wrt security bug #238574. (diff)
downloadgentoo-2-8b0bba37c6d079309bea10c7875442fef9bf25ec.tar.gz
gentoo-2-8b0bba37c6d079309bea10c7875442fef9bf25ec.tar.bz2
gentoo-2-8b0bba37c6d079309bea10c7875442fef9bf25ec.zip
bump
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'dev-scheme/bigloo/bigloo-3.1b.ebuild')
-rw-r--r--dev-scheme/bigloo/bigloo-3.1b.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/dev-scheme/bigloo/bigloo-3.1b.ebuild b/dev-scheme/bigloo/bigloo-3.1b.ebuild
new file mode 100644
index 000000000000..6061e5d58e7f
--- /dev/null
+++ b/dev-scheme/bigloo/bigloo-3.1b.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/bigloo/bigloo-3.1b.ebuild,v 1.1 2008/10/12 16:42:03 hkbst Exp $
+
+inherit elisp-common multilib
+
+MY_P=${PN}${PV/_p/-}
+MY_P=${MY_P/_alpha/-alpha}
+MY_P=${MY_P/_beta/-beta}
+
+DESCRIPTION="Bigloo is a Scheme implementation."
+HOMEPAGE="http://www-sop.inria.fr/mimosa/fp/Bigloo/bigloo.html"
+SRC_URI="ftp://ftp-sop.inria.fr/mimosa/fp/Bigloo/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-libs/boehm-gc
+ emacs? ( virtual/emacs )
+ java? ( virtual/jdk app-arch/zip )"
+
+RDEPEND="dev-libs/boehm-gc"
+
+S=${WORKDIR}/${MY_P%-*}
+
+SITEFILE="50bigloo-gentoo.el"
+
+IUSE="emacs java"
+# fullbee"
+
+src_compile() {
+ if use emacs; then
+ elisp-compile etc/*.el || die "elisp-compile failed"
+ fi
+
+ # Bigloo doesn't use autoconf and consequently a lot of options used by econf give errors
+ # Manuel Serrano says: "Please, dont talk to me about autoconf. I simply dont want to hear about it..."
+ ./configure \
+ $(use java && echo "--jvm=yes --java=$(java-config --java) --javac=$(java-config --javac)") \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --libdir=/usr/$(get_libdir) \
+ --docdir=/usr/share/doc/${PF} \
+ --benchmark=yes \
+ --sharedbde=no \
+ --sharedcompiler=no \
+ --customgc=no \
+ --coflags="" || die "configure failed"
+
+# --bee=$(if use fullbee; then echo full; else echo partial; fi) \
+
+ # parallel build is broken
+ emake -j1 || die "emake failed"
+}
+
+src_install () {
+# dodir /etc/env.d
+# echo "LDPATH=/usr/$(get_libdir)/bigloo/${PV}/" > ${D}/etc/env.d/25bigloo
+
+ # make the links created not point to DESTDIR, since that is only a temporary home
+ sed 's/ln -s $(DESTDIR)/ln -s /' -i Makefile.misc
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+
+ if use emacs; then
+ elisp-install ${PN} etc/*.{el,elc} || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+# einfo "Compiling bee..."
+# emake compile-bee || die "compiling bee failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}