summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-10-15 05:44:17 +0000
committerHans de Graaff <graaff@gentoo.org>2014-10-15 05:44:17 +0000
commitf8f3fef87cac1497acfb82bba223399983fb6aef (patch)
treecd10088dc84b3b10c78277728273691ebc98f933 /dev-ruby
parentsys-cluster/openmpi: bump (diff)
downloadgentoo-2-f8f3fef87cac1497acfb82bba223399983fb6aef.tar.gz
gentoo-2-f8f3fef87cac1497acfb82bba223399983fb6aef.tar.bz2
gentoo-2-f8f3fef87cac1497acfb82bba223399983fb6aef.zip
Version bump.
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/execjs/ChangeLog7
-rw-r--r--dev-ruby/execjs/execjs-2.2.2.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/execjs/ChangeLog b/dev-ruby/execjs/ChangeLog
index f8a8ac571f96..bae551146f6d 100644
--- a/dev-ruby/execjs/ChangeLog
+++ b/dev-ruby/execjs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/execjs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/execjs/ChangeLog,v 1.21 2014/09/04 02:53:46 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/execjs/ChangeLog,v 1.22 2014/10/15 05:44:17 graaff Exp $
+
+*execjs-2.2.2 (15 Oct 2014)
+
+ 15 Oct 2014; Hans de Graaff <graaff@gentoo.org> +execjs-2.2.2.ebuild:
+ Version bump.
04 Sep 2014; Manuel Rüger <mrueg@gentoo.org> execjs-1.4.0.ebuild:
Drop failing test. Move execjs-1.4 to SLOT=1
diff --git a/dev-ruby/execjs/execjs-2.2.2.ebuild b/dev-ruby/execjs/execjs-2.2.2.ebuild
new file mode 100644
index 000000000000..c3783c719980
--- /dev/null
+++ b/dev-ruby/execjs/execjs-2.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/execjs/execjs-2.2.2.ebuild,v 1.1 2014/10/15 05:44:17 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="ExecJS lets you run JavaScript code from Ruby"
+HOMEPAGE="https://github.com/sstephenson/execjs"
+SRC_URI="https://github.com/sstephenson/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+
+IUSE="test"
+
+# execjs supports various javascript runtimes. They are listed in order
+# as per the documentation. For now only include the ones already in the
+# tree.
+
+# therubyracer, therubyrhino, node.js, spidermonkey (deprecated)
+
+# spidermonkey doesn't pass the test suite:
+# https://github.com/sstephenson/execjs/issues/62
+
+RDEPEND+=" || ( net-libs/nodejs )"
+
+all_ruby_prepare() {
+ # Avoid test requiring network connectivity. We could potentially
+ # substitute dev-ruby/coffee-script-source for this.
+ sed -i -e '/test_coffeescript/,/end/ s:^:#:' test/test_execjs.rb || die
+}