summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-05-03 05:33:11 +0000
committerHans de Graaff <graaff@gentoo.org>2011-05-03 05:33:11 +0000
commite4489239388db0b5bfa9d78de27eb607016a5686 (patch)
tree041b6728c04f374763544efec5fe9ed1b4c75f93 /dev-ruby
parentUpdated to newer upstream version, including tests. (diff)
downloadgentoo-2-e4489239388db0b5bfa9d78de27eb607016a5686.tar.gz
gentoo-2-e4489239388db0b5bfa9d78de27eb607016a5686.tar.bz2
gentoo-2-e4489239388db0b5bfa9d78de27eb607016a5686.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/libxml/ChangeLog7
-rw-r--r--dev-ruby/libxml/libxml-2.0.4.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/libxml/ChangeLog b/dev-ruby/libxml/ChangeLog
index d16fb2535ad5..8a71eab4cc46 100644
--- a/dev-ruby/libxml/ChangeLog
+++ b/dev-ruby/libxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/libxml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.34 2011/04/21 05:35:50 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/ChangeLog,v 1.35 2011/05/03 05:33:11 graaff Exp $
+
+*libxml-2.0.4 (03 May 2011)
+
+ 03 May 2011; Hans de Graaff <graaff@gentoo.org> +libxml-2.0.4.ebuild:
+ Version bump.
*libxml-2.0.2 (21 Apr 2011)
diff --git a/dev-ruby/libxml/libxml-2.0.4.ebuild b/dev-ruby/libxml/libxml-2.0.4.ebuild
new file mode 100644
index 000000000000..3802f13d8573
--- /dev/null
+++ b/dev-ruby/libxml/libxml-2.0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/libxml/libxml-2.0.4.ebuild,v 1.1 2011/05/03 05:33:11 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_NAME="libxml-ruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster."
+HOMEPAGE="http://libxml.rubyforge.org"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="${RDEPEND} dev-libs/libxml2"
+DEPEND="${DEPEND} dev-libs/libxml2"
+
+all_ruby_prepare() {
+ # Remove grancher tasks only needed for publishing the website
+ sed -i -e '/grancher/d' -e '/Grancher/,$d' Rakefile || die
+
+ # We don't have the hanna template available.
+ sed -i -e 's/hanna/rake/' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/libxml extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/libxml
+ cp ext/libxml/libxml_ruby.so lib/ || die
+}