summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-12-16 20:11:15 +0000
committerHans de Graaff <graaff@gentoo.org>2013-12-16 20:11:15 +0000
commite141ab87c898332f6dc11d8098e3b35bbd9a26e5 (patch)
treecedb114c587700ca8fe7aa9d10db88540ed4f8e8 /dev-ruby
parentCleanup for security bug 493284. (diff)
downloadgentoo-2-e141ab87c898332f6dc11d8098e3b35bbd9a26e5.tar.gz
gentoo-2-e141ab87c898332f6dc11d8098e3b35bbd9a26e5.tar.bz2
gentoo-2-e141ab87c898332f6dc11d8098e3b35bbd9a26e5.zip
Cleanup for security bug 493284.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activemodel/ChangeLog6
-rw-r--r--dev-ruby/activemodel/activemodel-3.2.15.ebuild50
-rw-r--r--dev-ruby/activemodel/activemodel-4.0.0.ebuild46
3 files changed, 5 insertions, 97 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 9103a73f09e3..a19cc53e9fba 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.66 2013/12/04 19:23:19 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.67 2013/12/16 20:11:15 graaff Exp $
+
+ 16 Dec 2013; Hans de Graaff <graaff@gentoo.org> -activemodel-3.2.15.ebuild,
+ -activemodel-4.0.0.ebuild:
+ Cleanup for security bug 493284.
*activemodel-4.0.2 (04 Dec 2013)
diff --git a/dev-ruby/activemodel/activemodel-3.2.15.ebuild b/dev-ruby/activemodel/activemodel-3.2.15.ebuild
deleted file mode 100644
index 780f3cb1c72a..000000000000
--- a/dev-ruby/activemodel/activemodel-3.2.15.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.2.15.ebuild,v 1.1 2013/10/17 06:34:40 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
-HOMEPAGE="http://github.com/rails/rails"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/builder-3.0.0:3
- >=dev-ruby/bcrypt-ruby-3.0.0"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/test-unit:2
- >=dev-ruby/mocha-0.13.0:0.13
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
-
- # Make sure we use the test-unit gem since ruby18 does not provide
- # all the test-unit features needed.
- sed -i -e '1igem "test-unit"' test/cases/helper.rb || die
-
- # Fix bcrypt dependency since bcrypt uses semantic versioning.
- sed -i -e '/bcrypt-ruby/ s/3.0.0/3.0/' lib/active_model/secure_password.rb || die
-}
diff --git a/dev-ruby/activemodel/activemodel-4.0.0.ebuild b/dev-ruby/activemodel/activemodel-4.0.0.ebuild
deleted file mode 100644
index 3c2e0fd312ee..000000000000
--- a/dev-ruby/activemodel/activemodel-4.0.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-4.0.0.ebuild,v 1.2 2013/10/13 22:07:48 maekke Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
-HOMEPAGE="http://github.com/rails/rails"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/builder-3.1.0:3.1
- >=dev-ruby/bcrypt-ruby-3.0.0"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/railties-4.0.0
- dev-ruby/test-unit:2
- >=dev-ruby/mocha-0.13.0:0.13
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
-
- # Fix bcrypt dependency since bcrypt uses semantic versioning.
- sed -i -e '/bcrypt-ruby/ s/3.0.0/3.0/' lib/active_model/secure_password.rb || die
-}