summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-13 05:47:55 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-13 05:47:55 +0000
commitcba54dbfb59ac5958f9c5462897359fe1221dc5c (patch)
tree67afeecd18ae7fc893e8a5b2b26917c418220629 /dev-ruby
parentRemove old versions. (diff)
downloadgentoo-2-cba54dbfb59ac5958f9c5462897359fe1221dc5c.tar.gz
gentoo-2-cba54dbfb59ac5958f9c5462897359fe1221dc5c.tar.bz2
gentoo-2-cba54dbfb59ac5958f9c5462897359fe1221dc5c.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/minitest/ChangeLog7
-rw-r--r--dev-ruby/minitest/minitest-2.1.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-ruby/minitest/ChangeLog b/dev-ruby/minitest/ChangeLog
index c7665c41e652..5bc9802735da 100644
--- a/dev-ruby/minitest/ChangeLog
+++ b/dev-ruby/minitest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/minitest
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.39 2011/04/13 05:42:53 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.40 2011/04/13 05:47:55 graaff Exp $
+
+*minitest-2.1.0 (13 Apr 2011)
+
+ 13 Apr 2011; Hans de Graaff <graaff@gentoo.org> +minitest-2.1.0.ebuild:
+ Version bump.
13 Apr 2011; Hans de Graaff <graaff@gentoo.org> -minitest-1.6.0.ebuild,
-minitest-1.7.2.ebuild:
diff --git a/dev-ruby/minitest/minitest-2.1.0.ebuild b/dev-ruby/minitest/minitest-2.1.0.ebuild
new file mode 100644
index 000000000000..9dab6ce6971a
--- /dev/null
+++ b/dev-ruby/minitest/minitest-2.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/minitest-2.1.0.ebuild,v 1.1 2011/04/13 05:47:55 graaff Exp $
+
+EAPI=2
+# jruby → tests fail, reported upstream
+# http://rubyforge.org/tracker/index.php?func=detail&aid=27657&group_id=1040&atid=4097
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="minitest/unit is a small and fast replacement for ruby's huge and slow test/unit."
+HOMEPAGE="http://rubyforge.org/projects/bfts"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/hoe )
+ test? (
+ virtual/ruby-test-unit
+ dev-ruby/hoe
+ )"
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ eqawarn "Skipping tests on JRuby, bug 321055."
+ ;;
+ *)
+ each_fakegem_test
+ ;;
+ esac
+}