summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-01 06:08:16 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-01 06:08:16 +0000
commitb399bebc2dc9e9aee376c0ff6d4d752165eba3ba (patch)
treefc7b2051342c9cad071a31e02f29583b04d87b48 /dev-ruby
parentRemove old versions. (diff)
downloadgentoo-2-b399bebc2dc9e9aee376c0ff6d4d752165eba3ba.tar.gz
gentoo-2-b399bebc2dc9e9aee376c0ff6d4d752165eba3ba.tar.bz2
gentoo-2-b399bebc2dc9e9aee376c0ff6d4d752165eba3ba.zip
Remove old versions.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activerecord/ChangeLog6
-rw-r--r--dev-ruby/activerecord/activerecord-3.0.10.ebuild61
-rw-r--r--dev-ruby/activerecord/activerecord-3.0.11.ebuild61
3 files changed, 5 insertions, 123 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index a39383ef3927..b03d12d2f9a1 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.183 2012/05/17 10:52:20 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.184 2012/06/01 06:08:16 graaff Exp $
+
+ 01 Jun 2012; Hans de Graaff <graaff@gentoo.org> -activerecord-3.0.10.ebuild,
+ -activerecord-3.0.11.ebuild:
+ Remove old versions.
17 May 2012; Thomas Kahle <tomka@gentoo.org> activerecord-3.1.4.ebuild,
activerecord-3.2.3.ebuild:
diff --git a/dev-ruby/activerecord/activerecord-3.0.10.ebuild b/dev-ruby/activerecord/activerecord-3.0.10.ebuild
deleted file mode 100644
index d02a001a8fa9..000000000000
--- a/dev-ruby/activerecord/activerecord-3.0.10.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.0.10.ebuild,v 1.2 2012/05/01 18:24:21 armin76 Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-rails-*/activerecord"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-2.0.10-r1:2.0
- >=dev-ruby/tzinfo-0.3.23
- sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.3 )
- mysql? ( dev-ruby/mysql2:0.2 )
- postgres? ( dev-ruby/pg )"
-
-ruby_add_bdepend "
- test? (
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-ruby-1.3.3
- >=dev-ruby/mocha-0.9.5
- virtual/ruby-test-unit
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}
diff --git a/dev-ruby/activerecord/activerecord-3.0.11.ebuild b/dev-ruby/activerecord/activerecord-3.0.11.ebuild
deleted file mode 100644
index 745c55fdac68..000000000000
--- a/dev-ruby/activerecord/activerecord-3.0.11.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.0.11.ebuild,v 1.2 2012/05/01 18:24:21 armin76 Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-rails-*/activerecord"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-2.0.10-r1:2.0
- >=dev-ruby/tzinfo-0.3.23
- sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.3 )
- mysql? ( dev-ruby/mysql2:0.2 )
- postgres? ( dev-ruby/pg )"
-
-ruby_add_bdepend "
- test? (
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-ruby-1.3.3
- >=dev-ruby/mocha-0.9.5
- virtual/ruby-test-unit
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}