summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2012-03-14 16:16:47 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2012-03-14 16:16:47 +0000
commit8e7831263c0bf89ce6b9f0b6e5fdbb97a2874c8f (patch)
tree485a0751a2f560243596ab6065f7253d8db00128 /dev-ruby
parentVersion bump for dev channel release. Remove old. (diff)
downloadgentoo-2-8e7831263c0bf89ce6b9f0b6e5fdbb97a2874c8f.tar.gz
gentoo-2-8e7831263c0bf89ce6b9f0b6e5fdbb97a2874c8f.tar.bz2
gentoo-2-8e7831263c0bf89ce6b9f0b6e5fdbb97a2874c8f.zip
Version bumped. Fixed HOMEPAGE. Clean up.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-ldap/ChangeLog9
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.9.12.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-ruby/ruby-ldap/ChangeLog b/dev-ruby/ruby-ldap/ChangeLog
index a78f9159592e..daf2fc22dbf4 100644
--- a/dev-ruby/ruby-ldap/ChangeLog
+++ b/dev-ruby/ruby-ldap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-ldap
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-ldap/ChangeLog,v 1.51 2011/12/26 07:55:44 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-ldap/ChangeLog,v 1.52 2012/03/14 16:16:47 matsuu Exp $
+
+*ruby-ldap-0.9.12 (14 Mar 2012)
+
+ 14 Mar 2012; MATSUU Takuto <matsuu@gentoo.org> +ruby-ldap-0.9.12.ebuild:
+ Version bumped. Fixed HOMEPAGE. Clean up.
26 Dec 2011; Hans de Graaff <graaff@gentoo.org> -ruby-ldap-0.9.9.ebuild:
Remove old version.
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.9.12.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.9.12.ebuild
new file mode 100644
index 000000000000..6f6510451354
--- /dev/null
+++ b/dev-ruby/ruby-ldap/ruby-ldap-0.9.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-ldap/ruby-ldap-0.9.12.ebuild,v 1.1 2012/03/14 16:16:47 matsuu Exp $
+
+EAPI="4"
+# jruby: mkmf
+# rbx: require 'ldap' no such file to load
+USE_RUBY="ruby18 ruby19 ree18"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog FAQ NOTES README TODO"
+
+DESCRIPTION="A Ruby interface to some LDAP libraries"
+HOMEPAGE="http://ruby-ldap.sourceforge.net/"
+SRC_URI="mirror://rubygems/${P}.gem"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-macos"
+IUSE="ssl"
+DEPEND=">=net-nds/openldap-2
+ dev-libs/cyrus-sasl
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+# Current test set is interactive due to certificate generation and requires
+# running LDAP daemon
+RESTRICT="test"
+
+each_ruby_configure() {
+ local myconf="--with-openldap2"
+ if ! use ssl ; then
+ myconf="${myconf} --without-libcrypto --without-libssl"
+ fi
+ ${RUBY} extconf.rb ${myconf} || die "extconf.rb failed"
+ sed -i -e 's:-Wl,--no-undefined::' \
+ -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" Makefile || die
+}
+
+each_ruby_compile() {
+ emake || die
+ cp ldap.so lib/
+}