summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-02-02 14:00:40 +0000
committerHans de Graaff <graaff@gentoo.org>2013-02-02 14:00:40 +0000
commit87ff75a449fb29ae264453ddb31d4316e90c4cb1 (patch)
tree23fd8660c51038063dff8f347ec5dc8a07f82151 /dev-ruby
parentDrop old, add prefix keywords (diff)
downloadgentoo-2-87ff75a449fb29ae264453ddb31d4316e90c4cb1.tar.gz
gentoo-2-87ff75a449fb29ae264453ddb31d4316e90c4cb1.tar.bz2
gentoo-2-87ff75a449fb29ae264453ddb31d4316e90c4cb1.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/gnuplot/ChangeLog7
-rw-r--r--dev-ruby/gnuplot/gnuplot-2.6.2.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-ruby/gnuplot/ChangeLog b/dev-ruby/gnuplot/ChangeLog
index 2bea575fe016..9a9577a2b819 100644
--- a/dev-ruby/gnuplot/ChangeLog
+++ b/dev-ruby/gnuplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/gnuplot
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/ChangeLog,v 1.18 2013/02/02 13:59:02 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/ChangeLog,v 1.19 2013/02/02 14:00:40 graaff Exp $
+
+*gnuplot-2.6.2 (02 Feb 2013)
+
+ 02 Feb 2013; Hans de Graaff <graaff@gentoo.org> +gnuplot-2.6.2.ebuild:
+ Version bump.
02 Feb 2013; Hans de Graaff <graaff@gentoo.org> -gnuplot-2.4.1.ebuild,
-gnuplot-2.5.0.ebuild:
diff --git a/dev-ruby/gnuplot/gnuplot-2.6.2.ebuild b/dev-ruby/gnuplot/gnuplot-2.6.2.ebuild
new file mode 100644
index 000000000000..29d390f051c9
--- /dev/null
+++ b/dev-ruby/gnuplot/gnuplot-2.6.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/gnuplot-2.6.2.ebuild,v 1.1 2013/02/02 14:00:40 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS.txt ChangeLog README.textile"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Gnuplot drawing library - Ruby Bindings"
+HOMEPAGE="http://rgplot.rubyforge.org/"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+SLOT="0"
+
+RDEPEND="${RDEPEND} sci-visualization/gnuplot"
+
+all_ruby_prepare() {
+ # Existing metadata causes a crash in jruby, so use our own.
+ rm ../metadata || die "Unable to remove metadata."
+}
+
+each_ruby_test() {
+ ${RUBY} -Ctest test_gnuplot.rb || die
+}