summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-04 19:32:03 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-04 19:32:03 +0000
commit7ff03b6af18651dd5edaf81f87d3de01bce3d523 (patch)
tree6f9e6afb9b989bbcb263416b7833871450466eef /dev-ruby
parentUnmask tests as they all seem to pass on my computer. Lets see what users obs... (diff)
downloadgentoo-2-7ff03b6af18651dd5edaf81f87d3de01bce3d523.tar.gz
gentoo-2-7ff03b6af18651dd5edaf81f87d3de01bce3d523.tar.bz2
gentoo-2-7ff03b6af18651dd5edaf81f87d3de01bce3d523.zip
Add new stable candidate revision with proper dependency on dev-ruby/rdoc, as reported in bug 357939.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/test-unit/ChangeLog9
-rw-r--r--dev-ruby/test-unit/test-unit-2.1.2-r1.ebuild44
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 0c1489bdac5f..a275a65d6579 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.35 2011/03/09 10:37:31 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.36 2011/04/04 19:32:03 graaff Exp $
+
+*test-unit-2.1.2-r1 (04 Apr 2011)
+
+ 04 Apr 2011; Hans de Graaff <graaff@gentoo.org>
+ +test-unit-2.1.2-r1.ebuild:
+ Add new stable candidate revision with proper dependency on dev-ruby/rdoc,
+ as reported in bug 357939.
09 Mar 2011; Markos Chandras <hwoarang@gentoo.org> test-unit-2.1.2.ebuild:
Stable on amd64 wrt bug #357939
diff --git a/dev-ruby/test-unit/test-unit-2.1.2-r1.ebuild b/dev-ruby/test-unit/test-unit-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..090aedece4ba
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-2.1.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.1.2-r1.ebuild,v 1.1 2011/04/04 19:32:03 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="TODO README.txt History.txt"
+
+# Disable default binwraps
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+ruby_add_bdepend "doc? ( dev-ruby/hoe dev-ruby/rdoc )"
+
+DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
+HOMEPAGE="http://test-unit.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+each_ruby_test() {
+ # the rake audit using dev-ruby/zentest currently fails, and we
+ # just need to call the testsuite directly.
+ # rake audit || die "rake audit failed"
+ local rubyflags
+
+ [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
+
+ ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
+ # rdoc-2* series.
+ ruby_fakegem_binwrapper testrb /usr/bin/testrb-2
+}