summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-14 22:50:01 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-14 22:50:01 +0000
commit6590a6c33fe8014cb094d165e0dba9279c41f20b (patch)
tree69f54e74b3635c80312a55494ebadd9a9e89ef76 /dev-ruby
parentNew virtual, bug 525134 (diff)
downloadgentoo-2-6590a6c33fe8014cb094d165e0dba9279c41f20b.tar.gz
gentoo-2-6590a6c33fe8014cb094d165e0dba9279c41f20b.tar.bz2
gentoo-2-6590a6c33fe8014cb094d165e0dba9279c41f20b.zip
Version bump. Add ruby21. Add tests (test_async_clear_environment failing).
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-glib2/ChangeLog7
-rw-r--r--dev-ruby/ruby-glib2/ruby-glib2-2.2.2.ebuild24
2 files changed, 30 insertions, 1 deletions
diff --git a/dev-ruby/ruby-glib2/ChangeLog b/dev-ruby/ruby-glib2/ChangeLog
index b57f87c49876..cf57dd77da34 100644
--- a/dev-ruby/ruby-glib2/ChangeLog
+++ b/dev-ruby/ruby-glib2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-glib2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-glib2/ChangeLog,v 1.113 2014/05/21 01:40:18 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-glib2/ChangeLog,v 1.114 2014/10/14 22:50:01 mrueg Exp $
+
+*ruby-glib2-2.2.2 (14 Oct 2014)
+
+ 14 Oct 2014; Manuel Rüger <mrueg@gentoo.org> +ruby-glib2-2.2.2.ebuild:
+ Version bump. Add ruby21. Add tests (test_async_clear_environment failing).
21 May 2014; Manuel Rüger <mrueg@gentoo.org> ruby-glib2-1.1.8.ebuild,
ruby-glib2-1.2.6.ebuild:
diff --git a/dev-ruby/ruby-glib2/ruby-glib2-2.2.2.ebuild b/dev-ruby/ruby-glib2/ruby-glib2-2.2.2.ebuild
new file mode 100644
index 000000000000..2e7002853165
--- /dev/null
+++ b/dev-ruby/ruby-glib2/ruby-glib2-2.2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-glib2/ruby-glib2-2.2.2.ebuild,v 1.1 2014/10/14 22:50:01 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit ruby-ng-gnome2
+
+DESCRIPTION="Ruby Glib2 bindings"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+RDEPEND+=" >=dev-libs/glib-2"
+DEPEND+=" >=dev-libs/glib-2"
+
+ruby_add_bdepend "dev-ruby/pkg-config"
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}