summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-03-03 18:42:02 +0000
committerHans de Graaff <graaff@gentoo.org>2013-03-03 18:42:02 +0000
commit2825be193b1e3c78b5c7d75626b3f1022e949466 (patch)
treea809439743fb289c25844aacd3d47f1df7da1f57 /dev-ruby
parentCleanup. (diff)
downloadgentoo-2-2825be193b1e3c78b5c7d75626b3f1022e949466.tar.gz
gentoo-2-2825be193b1e3c78b5c7d75626b3f1022e949466.tar.bz2
gentoo-2-2825be193b1e3c78b5c7d75626b3f1022e949466.zip
Version bump for security bug 460168.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/httparty/ChangeLog7
-rw-r--r--dev-ruby/httparty/httparty-0.10.2.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-ruby/httparty/ChangeLog b/dev-ruby/httparty/ChangeLog
index 6c2e003e4e09..ceb3ce61f51c 100644
--- a/dev-ruby/httparty/ChangeLog
+++ b/dev-ruby/httparty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/httparty
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/ChangeLog,v 1.24 2013/03/03 18:35:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/ChangeLog,v 1.25 2013/03/03 18:42:02 graaff Exp $
+
+*httparty-0.10.2 (03 Mar 2013)
+
+ 03 Mar 2013; Hans de Graaff <graaff@gentoo.org> +httparty-0.10.2.ebuild:
+ Version bump for security bug 460168.
03 Mar 2013; Hans de Graaff <graaff@gentoo.org> -httparty-0.6.1.ebuild,
-httparty-0.8.3.ebuild:
diff --git a/dev-ruby/httparty/httparty-0.10.2.ebuild b/dev-ruby/httparty/httparty-0.10.2.ebuild
new file mode 100644
index 000000000000..8d076e978497
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.10.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httparty/httparty-0.10.2.ebuild,v 1.1 2013/03/03 18:42:02 graaff Exp $
+
+EAPI=5
+
+# jruby → testsuite fails (seems like a testuite bug)
+USE_RUBY="ruby18 ruby19 ree18"
+
+# We have a custom test function, but don't null this out so that the
+# deps are still added
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md History"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy."
+HOMEPAGE="http://httparty.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_rdepend '=dev-ruby/multi_json-1* >=dev-ruby/multi_xml-0.5.2'
+
+ruby_add_bdepend 'dev-ruby/rspec:0 dev-ruby/fakeweb'
+
+USE_RUBY=ruby18 \
+ ruby_add_bdepend 'test? ( dev-util/cucumber www-servers/mongrel )'
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+# sed -i -e '/git ls-files/ s:^:#:' ${PN}.gemspec || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby18)
+ # Cucumber-based tests only work on Ruby 1.8, as of today, so we only call them
+ ${RUBY} -S rake spec features || die "cucumber tests failed"
+ ;;
+ *)
+ ${RUBY} -S rake spec || die "cucumber tests failed"
+ ;;
+ esac
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}