summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2009-05-03 19:59:48 +0000
committerHans de Graaff <graaff@gentoo.org>2009-05-03 19:59:48 +0000
commit25a50b29fa054efefa9e221ca861d3c5904409bc (patch)
tree256c3ea2bfd6a2a8046735b627c3361063f57a96 /dev-ruby
parentMask app-doc/afsdoc for removal. (diff)
downloadgentoo-2-25a50b29fa054efefa9e221ca861d3c5904409bc.tar.gz
gentoo-2-25a50b29fa054efefa9e221ca861d3c5904409bc.tar.bz2
gentoo-2-25a50b29fa054efefa9e221ca861d3c5904409bc.zip
Bump version to use upstream tarball instead of gem.
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rcairo/ChangeLog12
-rw-r--r--dev-ruby/rcairo/rcairo-1.8.0-r1.ebuild41
-rw-r--r--dev-ruby/rcairo/rcairo-1.8.0.ebuild6
3 files changed, 55 insertions, 4 deletions
diff --git a/dev-ruby/rcairo/ChangeLog b/dev-ruby/rcairo/ChangeLog
index d9c48bd8e6de..4e80da613f5d 100644
--- a/dev-ruby/rcairo/ChangeLog
+++ b/dev-ruby/rcairo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/rcairo
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/ChangeLog,v 1.27 2008/10/16 09:22:47 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/ChangeLog,v 1.28 2009/05/03 19:59:48 graaff Exp $
+
+*rcairo-1.8.0-r1 (03 May 2009)
+
+ 03 May 2009; Hans de Graaff <graaff@gentoo.org> rcairo-1.8.0.ebuild,
+ +rcairo-1.8.0-r1.ebuild:
+ Switch away from the gem because the gem Makefile has weird issues when
+ installing in some instances, see bug #264272. Install fake gemspec to
+ hopefully keep software depending on the gem being installed working.
16 Oct 2008; Diego Pettenò <flameeyes@gentoo.org> rcairo-1.8.0.ebuild:
Add missing IUSE.
diff --git a/dev-ruby/rcairo/rcairo-1.8.0-r1.ebuild b/dev-ruby/rcairo/rcairo-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..fc352b3b18d9
--- /dev/null
+++ b/dev-ruby/rcairo/rcairo-1.8.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/rcairo-1.8.0-r1.ebuild,v 1.1 2009/05/03 19:59:48 graaff Exp $
+
+inherit ruby
+
+IUSE=""
+
+DESCRIPTION="Ruby bindings for cairo"
+HOMEPAGE="http://cairographics.org/rcairo/"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( Ruby GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+USE_RUBY="ruby18"
+
+RDEPEND=">=x11-libs/cairo-1.2.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+dofakegemspec() {
+ cat - > "${T}"/${P}.gemspec <<EOF
+Gem::Specification.new do |s|
+ s.name = "${PN}"
+ s.version = "${PV}"
+ s.summary = "${DESCRIPTION}"
+ s.homepage = "${HOMEPAGE}"
+end
+EOF
+
+ insinto $(${RUBY} -r rbconfig -e 'print Config::CONFIG["vendorlibdir"]' | sed -e 's:vendor_ruby:gems:')/specifications
+ doins "${T}"/${P}.gemspec || die "Unable to install fake gemspec"
+}
+
+src_install() {
+ ruby_src_install
+
+ dofakegemspec
+}
diff --git a/dev-ruby/rcairo/rcairo-1.8.0.ebuild b/dev-ruby/rcairo/rcairo-1.8.0.ebuild
index 535b17ef4d41..32a3962a9609 100644
--- a/dev-ruby/rcairo/rcairo-1.8.0.ebuild
+++ b/dev-ruby/rcairo/rcairo-1.8.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/rcairo-1.8.0.ebuild,v 1.2 2008/10/16 09:22:47 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcairo/rcairo-1.8.0.ebuild,v 1.3 2009/05/03 19:59:48 graaff Exp $
inherit gems
@@ -16,6 +16,8 @@ SLOT="0"
LICENSE="|| ( Ruby GPL-2 )"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+USE_RUBY="ruby18"
+
RDEPEND=">=x11-libs/cairo-1.2.0"
DEPEND="${RDEPEND}
dev-util/pkgconfig"