summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-05-04 15:38:12 +0000
committerHans de Graaff <graaff@gentoo.org>2013-05-04 15:38:12 +0000
commit110e473f5860da8ef148c77d5a734a3573e38d6f (patch)
tree5219faee19138018693be3fbdbfe4578355c1a15 /dev-ruby
parentMove restartcmd to new 'helpers' subdirectory, bug 468506 by Michał Bartoszk... (diff)
downloadgentoo-2-110e473f5860da8ef148c77d5a734a3573e38d6f.tar.gz
gentoo-2-110e473f5860da8ef148c77d5a734a3573e38d6f.tar.bz2
gentoo-2-110e473f5860da8ef148c77d5a734a3573e38d6f.zip
Version bump.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hike/ChangeLog7
-rw-r--r--dev-ruby/hike/hike-1.2.2.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-ruby/hike/ChangeLog b/dev-ruby/hike/ChangeLog
index 6eeadc1469f5..b41068daebb3 100644
--- a/dev-ruby/hike/ChangeLog
+++ b/dev-ruby/hike/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/hike
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hike/ChangeLog,v 1.7 2013/01/15 06:26:35 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hike/ChangeLog,v 1.8 2013/05/04 15:38:12 graaff Exp $
+
+*hike-1.2.2 (04 May 2013)
+
+ 04 May 2013; Hans de Graaff <graaff@gentoo.org> +hike-1.2.2.ebuild:
+ Version bump.
15 Jan 2013; Rick Farina <zerochaos@gentoo.org> hike-1.2.1.ebuild:
adding ~arm keywords to net-analyzer/metasploit rdeps
diff --git a/dev-ruby/hike/hike-1.2.2.ebuild b/dev-ruby/hike/hike-1.2.2.ebuild
new file mode 100644
index 000000000000..ea1174175218
--- /dev/null
+++ b/dev-ruby/hike/hike-1.2.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hike/hike-1.2.2.ebuild,v 1.1 2013/05/04 15:38:12 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hike is a Ruby library for finding files in a set of paths."
+HOMEPAGE="https://github.com/sstephenson/hike"
+LICENSE="MIT"
+SRC_URI="https://github.com/sstephenson/hike/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test -S testrb test || die
+}