summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-21 11:13:14 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-21 11:13:14 +0000
commit0edd935ed7e6e0bc9ed86b1669d15b63575c5a5d (patch)
tree020d43269bb05d35cded382838a08d1aa16aa349 /dev-ruby
parentChanged license ACME -> BSD-2 (see bug #301121) (diff)
downloadgentoo-2-0edd935ed7e6e0bc9ed86b1669d15b63575c5a5d.tar.gz
gentoo-2-0edd935ed7e6e0bc9ed86b1669d15b63575c5a5d.tar.bz2
gentoo-2-0edd935ed7e6e0bc9ed86b1669d15b63575c5a5d.zip
Version bump, remove Ruby 1.9 support as it's not testable right now (actionpack is needed rather than just rack), add hpricot to the runtime dependencies.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/haml/ChangeLog9
-rw-r--r--dev-ruby/haml/haml-2.2.17.ebuild42
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index 941a7f91ad7e..3a3f3c7db4e0 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.32 2010/01/18 20:34:49 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.33 2010/01/21 11:13:14 flameeyes Exp $
+
+*haml-2.2.17 (21 Jan 2010)
+
+ 21 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org> +haml-2.2.17.ebuild:
+ Version bump, remove Ruby 1.9 support as it's not testable right now
+ (actionpack is needed rather than just rack), add hpricot to the runtime
+ dependencies.
18 Jan 2010; Brent Baude <ranger@gentoo.org> haml-2.2.16.ebuild:
Marking haml-2.2.16 ~ppc for bug 297718
diff --git a/dev-ruby/haml/haml-2.2.17.ebuild b/dev-ruby/haml/haml-2.2.17.ebuild
new file mode 100644
index 000000000000..a4718d183594
--- /dev/null
+++ b/dev-ruby/haml/haml-2.2.17.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-2.2.17.ebuild,v 1.1 2010/01/21 11:13:14 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HAML - a ruby web page templating engine"
+HOMEPAGE="http://haml.hamptoncatlin.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64"
+
+# TODO: haml has some emacs modes that it could be installing, in case
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/haml.gemspec/,/Task\[:package\]/s:^:#:' "${S}"/Rakefile
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # This is needed otherwise it fails at runtime
+ ruby_fakegem_doins VERSION VERSION_NAME
+}
+
+# The html engine requires hpricot
+ruby_add_rdepend dev-ruby/hpricot
+
+# It could use merb during testing as well, but it's not mandatory
+ruby_add_bdepend test "virtual/ruby-test-unit dev-ruby/actionpack"
+ruby_add_bdepend doc "dev-ruby/yard dev-ruby/maruku"