summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-12 19:39:01 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-12-12 19:39:01 +0000
commit82607b87af3d5115182d5e0defd6e50e967a1f08 (patch)
tree97527941d2ab0defc3338abc14e63e972bee33ef /dev-ruby/tzinfo
parentamd64 stable, bug 239341 (diff)
downloadgentoo-2-82607b87af3d5115182d5e0defd6e50e967a1f08.tar.gz
gentoo-2-82607b87af3d5115182d5e0defd6e50e967a1f08.tar.bz2
gentoo-2-82607b87af3d5115182d5e0defd6e50e967a1f08.zip
Remove old version, add new revision that does not use the gem but rather the tarball package.
(Portage version: 2.2_rc17/cvs/Linux 2.6.27-gentoo-r5 x86_64)
Diffstat (limited to 'dev-ruby/tzinfo')
-rw-r--r--dev-ruby/tzinfo/ChangeLog9
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.12-r1.ebuild49
-rw-r--r--dev-ruby/tzinfo/tzinfo-0.3.8.ebuild13
3 files changed, 57 insertions, 14 deletions
diff --git a/dev-ruby/tzinfo/ChangeLog b/dev-ruby/tzinfo/ChangeLog
index 595a794fcee8..02ce994b49b1 100644
--- a/dev-ruby/tzinfo/ChangeLog
+++ b/dev-ruby/tzinfo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/tzinfo
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.24 2008/11/12 23:10:54 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/ChangeLog,v 1.25 2008/12/12 19:39:01 flameeyes Exp $
+
+*tzinfo-0.3.12-r1 (12 Dec 2008)
+
+ 12 Dec 2008; Diego E. Pettenò <flameeyes@gentoo.org>
+ -tzinfo-0.3.8.ebuild, +tzinfo-0.3.12-r1.ebuild:
+ Remove old version, add new revision that does not use the gem but rather
+ the tarball package.
*tzinfo-0.3.12 (12 Nov 2008)
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.12-r1.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.12-r1.ebuild
new file mode 100644
index 000000000000..4090bb9f3273
--- /dev/null
+++ b/dev-ruby/tzinfo/tzinfo-0.3.12-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.12-r1.ebuild,v 1.1 2008/12/12 19:39:01 flameeyes Exp $
+
+inherit ruby
+
+DESCRIPTION="Library to provide daylight-savings aware transformations between timezones"
+HOMEPAGE="http://tzinfo.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="doc? ( dev-ruby/rake )
+ test? ( dev-ruby/rake )"
+
+USE_RUBY="ruby18"
+
+src_unpack() {
+ unpack ${A}
+
+ # The package has all the files executable, probably coming from
+ # Windows.
+ find "${S}" -type f -perm +111 -exec chmod -x {} +
+}
+
+src_compile() {
+ if use doc; then
+ rake rerdoc || die "rake rerdoc failed"
+ fi
+}
+
+src_test() {
+ rake test || die "rake test failed"
+}
+
+src_install() {
+ cd "${S}"/lib
+ doruby -r * || die "doruby failed"
+
+ if use doc; then
+ dohtml -r "${S}"/doc/* || die "dohtml failed"
+ fi
+
+ dodoc "${S}"/CHANGES "${S}"/README || die "dodoc failed"
+}
diff --git a/dev-ruby/tzinfo/tzinfo-0.3.8.ebuild b/dev-ruby/tzinfo/tzinfo-0.3.8.ebuild
deleted file mode 100644
index 4a140acf16eb..000000000000
--- a/dev-ruby/tzinfo/tzinfo-0.3.8.ebuild
+++ /dev/null
@@ -1,13 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tzinfo/tzinfo-0.3.8.ebuild,v 1.6 2008/10/07 12:46:18 nixnut Exp $
-
-inherit gems
-
-DESCRIPTION="Library to provide daylight-savings aware transformations between timezones"
-HOMEPAGE="http://tzinfo.rubyforge.org/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86 ~x86-fbsd"
-IUSE=""