summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-10-02 11:41:02 +0000
committerHans de Graaff <graaff@gentoo.org>2010-10-02 11:41:02 +0000
commit84a4facad5a19473f129fffbf40dd409618595bc (patch)
treed1b2c11449b43c656107c5f0442e7cf7d213c375 /dev-ruby/thor
parentVersion bump. Add jruby. (diff)
downloadgentoo-2-84a4facad5a19473f129fffbf40dd409618595bc.tar.gz
gentoo-2-84a4facad5a19473f129fffbf40dd409618595bc.tar.bz2
gentoo-2-84a4facad5a19473f129fffbf40dd409618595bc.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/thor')
-rw-r--r--dev-ruby/thor/ChangeLog7
-rw-r--r--dev-ruby/thor/thor-0.14.2.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ruby/thor/ChangeLog b/dev-ruby/thor/ChangeLog
index 0d19432b862f..1528353bfedf 100644
--- a/dev-ruby/thor/ChangeLog
+++ b/dev-ruby/thor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/thor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/ChangeLog,v 1.1 2010/08/31 20:14:24 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/ChangeLog,v 1.2 2010/10/02 11:41:02 graaff Exp $
+
+*thor-0.14.2 (02 Oct 2010)
+
+ 02 Oct 2010; Hans de Graaff <graaff@gentoo.org> +thor-0.14.2.ebuild:
+ Version bump.
*thor-0.14.0 (31 Aug 2010)
diff --git a/dev-ruby/thor/thor-0.14.2.ebuild b/dev-ruby/thor/thor-0.14.2.ebuild
new file mode 100644
index 000000000000..a2ce8aa01c15
--- /dev/null
+++ b/dev-ruby/thor/thor-0.14.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.14.2.ebuild,v 1.1 2010/10/02 11:41:02 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.md"
+RUBY_FAKEGEM_BINWRAP="thor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A scripting framework that replaces rake and sake"
+HOMEPAGE="http://github.com/wycats/thor"
+
+SRC_URI="http://github.com/wycats/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/wycats-${PN}-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+ruby_add_bdepend "
+ test? ( dev-ruby/fakeweb )
+ doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ einfo $(pwd)
+ # Having VERSION in the docs makes the rdoc generation fail.
+ sed -i -e '/EXTRA_RDOC_FILES/s/"VERSION", //' Thorfile || die
+}
+
+all_ruby_compile() {
+ einfo $(pwd)
+ use doc && ruby -Ilib bin/thor rdoc || die "RDoc generation failed"
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib/ bin/thor spec || die "Tests for ${RUBY} failed"
+}