summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-02-15 09:49:03 +0000
committerHans de Graaff <graaff@gentoo.org>2015-02-15 09:49:03 +0000
commit5863d8212db46626638dca72cb305b52c67077e4 (patch)
treebebdd5b2d5004f21ad7e4137f50da3eaf4864dbe /dev-ruby/test-unit
parentAdd keywords from dev-lang/ruby since this code was already bundled there. (diff)
downloadgentoo-2-5863d8212db46626638dca72cb305b52c67077e4.tar.gz
gentoo-2-5863d8212db46626638dca72cb305b52c67077e4.tar.bz2
gentoo-2-5863d8212db46626638dca72cb305b52c67077e4.zip
Remove broken version.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog5
-rw-r--r--dev-ruby/test-unit/test-unit-3.0.9.ebuild59
2 files changed, 4 insertions, 60 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 1e111ee6ae19..bb85de8633de 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.108 2015/01/27 19:24:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.109 2015/02/15 09:49:03 graaff Exp $
+
+ 15 Feb 2015; Hans de Graaff <graaff@gentoo.org> -test-unit-3.0.9.ebuild:
+ Remove broken version.
*test-unit-3.0.9-r1 (27 Jan 2015)
diff --git a/dev-ruby/test-unit/test-unit-3.0.9.ebuild b/dev-ruby/test-unit/test-unit-3.0.9.ebuild
deleted file mode 100644
index 14a131c0f223..000000000000
--- a/dev-ruby/test-unit/test-unit-3.0.9.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-3.0.9.ebuild,v 1.2 2015/01/26 08:35:14 jer Exp $
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="TODO README.md doc/text/news.md"
-
-inherit ruby-fakegem
-
-# Assume for now that ruby22 is not eselected yet and only depend on
-# yard for the other ruby implementations. Without this assumption
-# bootstrapping ruby22 won't be possible due to the yard dependency
-# tree.
-USE_RUBY="${USE_RUBY/ruby22/}" ruby_add_bdepend "doc? ( dev-ruby/yard )"
-
-DESCRIPTION="An xUnit family unit testing framework for Ruby"
-HOMEPAGE="https://rubygems.org/gems/test-unit"
-
-LICENSE="|| ( Ruby GPL-2 ) PSF-2"
-SLOT="2"
-KEYWORDS="~amd64 ~hppa"
-IUSE="doc test"
-
-# power_assert does not work with ruby19 but is not needed for backward
-# compatibility:
-# https://github.com/k-tsj/power_assert/issues/8#issuecomment-71363455
-USE_RUBY="${USE_RUBY/ruby19/}" ruby_add_rdepend "dev-ruby/power_assert"
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19)
- # Remove metadata to avoid registering the unsupported
- # power_assert dependency.
- rm ../metadata || die
- ;;
- esac
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc; then
- yard doc --title ${PN} || die
- fi
-}
-
-each_ruby_test() {
- ${RUBY} test/run-test.rb || die "testsuite failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbin "${FILESDIR}"/testrb testrb-2
-}