summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-01 14:09:25 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-01 14:09:25 +0000
commitc53308b8b10a97eb92379b4556104b1a8b8a4eb9 (patch)
tree1112c18684269149ef06f3bb0814522e181f5ddd /dev-ruby/storable
parentFix call to use_enable. (diff)
downloadgentoo-2-c53308b8b10a97eb92379b4556104b1a8b8a4eb9.tar.gz
gentoo-2-c53308b8b10a97eb92379b4556104b1a8b8a4eb9.tar.bz2
gentoo-2-c53308b8b10a97eb92379b4556104b1a8b8a4eb9.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/storable')
-rw-r--r--dev-ruby/storable/ChangeLog8
-rw-r--r--dev-ruby/storable/storable-0.8.1.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-ruby/storable/ChangeLog b/dev-ruby/storable/ChangeLog
index 4091f3b2a2c8..0b45eeb20683 100644
--- a/dev-ruby/storable/ChangeLog
+++ b/dev-ruby/storable/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/storable
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.13 2010/07/28 23:22:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.14 2010/08/01 14:09:24 flameeyes Exp $
+
+*storable-0.8.1 (01 Aug 2010)
+
+ 01 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +storable-0.8.1.ebuild:
+ Version bump.
*storable-0.8.0 (28 Jul 2010)
diff --git a/dev-ruby/storable/storable-0.8.1.ebuild b/dev-ruby/storable/storable-0.8.1.ebuild
new file mode 100644
index 000000000000..b0be67611a43
--- /dev/null
+++ b/dev-ruby/storable/storable-0.8.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.8.1.ebuild,v 1.1 2010/08/01 14:09:25 flameeyes Exp $
+
+EAPI=2
+
+# jruby → yajl-ruby won't work, as it's compiled extension
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Marshal Ruby classes into and out of multiple formats"
+HOMEPAGE="http://solutious.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+SRC_URI="http://github.com/delano/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/delano-${PN}-*"
+
+# technically, it could work without either; on the other hand, it
+# would break a bit of stuff.
+#ruby_add_rdepend "|| ( dev-ruby/json dev-ruby/yajl-ruby )"
+
+# Somehow it infinite-recurse if JSON is used, see issue #1, so use
+# yajl directly.
+ruby_add_rdepend dev-ruby/yajl-ruby
+
+ruby_add_bdepend "test? ( dev-ruby/tryouts:2 )"
+
+all_ruby_prepare() {
+ mv bin examples || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S try || die "tests failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}