summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-11-05 20:17:55 +0000
committerHans de Graaff <graaff@gentoo.org>2013-11-05 20:17:55 +0000
commitca7811b48397c5b9ebbcf1bad15e9b8f50479521 (patch)
tree0d362816661dab70a49aae72839fa8d9cd7dfb9f /dev-ruby/shoulda
parentStable for amd64 wrt bug #488946 (diff)
downloadgentoo-2-ca7811b48397c5b9ebbcf1bad15e9b8f50479521.tar.gz
gentoo-2-ca7811b48397c5b9ebbcf1bad15e9b8f50479521.tar.bz2
gentoo-2-ca7811b48397c5b9ebbcf1bad15e9b8f50479521.zip
EAPI 5. Add ruby20.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/shoulda')
-rw-r--r--dev-ruby/shoulda/ChangeLog7
-rw-r--r--dev-ruby/shoulda/shoulda-2.11.3-r1.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-ruby/shoulda/ChangeLog b/dev-ruby/shoulda/ChangeLog
index ebd2ae24598f..93ccf0e33a59 100644
--- a/dev-ruby/shoulda/ChangeLog
+++ b/dev-ruby/shoulda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/shoulda
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shoulda/ChangeLog,v 1.19 2013/01/15 07:08:54 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shoulda/ChangeLog,v 1.20 2013/11/05 20:17:55 graaff Exp $
+
+*shoulda-2.11.3-r1 (05 Nov 2013)
+
+ 05 Nov 2013; Hans de Graaff <graaff@gentoo.org> +shoulda-2.11.3-r1.ebuild:
+ EAPI 5. Add ruby20.
15 Jan 2013; Rick Farina <zerochaos@gentoo.org> shoulda-2.11.3.ebuild:
adding ~arm keywords to net-analyzer/metasploit rdeps
diff --git a/dev-ruby/shoulda/shoulda-2.11.3-r1.ebuild b/dev-ruby/shoulda/shoulda-2.11.3-r1.ebuild
new file mode 100644
index 000000000000..835381221353
--- /dev/null
+++ b/dev-ruby/shoulda/shoulda-2.11.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shoulda/shoulda-2.11.3-r1.ebuild,v 1.1 2013/11/05 20:17:55 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTION_GUIDELINES.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+SRC_URI="https://github.com/thoughtbot/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+RUBY_S="thoughtbot-${PN}-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# tests seem to be quite broken :( They require working version of
+# various rails versions. There appear to be unit and matcher tests but
+# they can't be run on their own.
+RESTRICT=test