summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-03-29 07:15:47 +0000
committerHans de Graaff <graaff@gentoo.org>2015-03-29 07:15:47 +0000
commit9f435521574f953d80180cd35c2bce5611076735 (patch)
treea865e3f49ae9da0de44ee6ea04bc97ba836eb9e7 /dev-ruby/samuel
parentCreate stable candidate. (diff)
downloadgentoo-2-9f435521574f953d80180cd35c2bce5611076735.tar.gz
gentoo-2-9f435521574f953d80180cd35c2bce5611076735.tar.bz2
gentoo-2-9f435521574f953d80180cd35c2bce5611076735.zip
Create stable candidate.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/samuel')
-rw-r--r--dev-ruby/samuel/ChangeLog10
-rw-r--r--dev-ruby/samuel/samuel-0.3.3-r1.ebuild6
-rw-r--r--dev-ruby/samuel/samuel-0.3.3-r2.ebuild44
3 files changed, 55 insertions, 5 deletions
diff --git a/dev-ruby/samuel/ChangeLog b/dev-ruby/samuel/ChangeLog
index f942d0224afa..0952f807878b 100644
--- a/dev-ruby/samuel/ChangeLog
+++ b/dev-ruby/samuel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/samuel
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/samuel/ChangeLog,v 1.24 2014/10/30 15:57:38 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/samuel/ChangeLog,v 1.25 2015/03/29 07:15:47 graaff Exp $
+
+*samuel-0.3.3-r2 (29 Mar 2015)
+
+ 29 Mar 2015; Hans de Graaff <graaff@gentoo.org> samuel-0.3.3-r1.ebuild,
+ +samuel-0.3.3-r2.ebuild:
+ Create stable candidate.
30 Oct 2014; Manuel Rüger <mrueg@gentoo.org> -samuel-0.3.3.ebuild,
samuel-0.3.3-r1.ebuild:
diff --git a/dev-ruby/samuel/samuel-0.3.3-r1.ebuild b/dev-ruby/samuel/samuel-0.3.3-r1.ebuild
index d82fe7856a58..1cff32d0c725 100644
--- a/dev-ruby/samuel/samuel-0.3.3-r1.ebuild
+++ b/dev-ruby/samuel/samuel-0.3.3-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/samuel/samuel-0.3.3-r1.ebuild,v 1.6 2014/10/30 15:57:38 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/samuel/samuel-0.3.3-r1.ebuild,v 1.7 2015/03/29 07:15:47 graaff Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_TASK_DOC=""
diff --git a/dev-ruby/samuel/samuel-0.3.3-r2.ebuild b/dev-ruby/samuel/samuel-0.3.3-r2.ebuild
new file mode 100644
index 000000000000..39f1bfc77635
--- /dev/null
+++ b/dev-ruby/samuel/samuel-0.3.3-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/samuel/samuel-0.3.3-r2.ebuild,v 1.1 2015/03/29 07:15:47 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="An automatic logger for HTTP requests in Ruby"
+HOMEPAGE="http://github.com/chrisk/samuel"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/shoulda-2.11.3
+ >=dev-ruby/fakeweb-1.3
+ >=dev-ruby/httpclient-2.2.3
+ dev-ruby/mocha:0.13
+ dev-ruby/test-unit:2
+ )"
+
+all_ruby_prepare() {
+ # Remove references to bundler
+ sed -i -e '/[Bb]undler/d' test/test_helper.rb || die
+ rm Gemfile*
+
+ # Change the default port from 8000 to 64888 to sidestep Issue #10.
+ # https://github.com/chrisk/samuel/issues/10
+ sed -i -e 's:8000:64888:g' test/*.rb || die
+
+ # Require an old enough version of mocha.
+ sed -i -e '1igem "mocha", "~> 0.13.0"' test/test_helper.rb || die
+
+ # Use the test-unit gem to make jruby compatible with newer mocha.
+ sed -i -e '1igem "test-unit"' test/test_helper.rb || die
+}