summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-03-31 18:19:44 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-03-31 18:19:44 +0000
commit07b3054068b82597e7c28dd61b6b896240ec2f69 (patch)
tree8ee23403da4ad882c01f2e79cccd747cd99b44b0 /dev-ruby/rubygems/rubygems-0.8.11-r5.ebuild
parent~amd64 added; thanks to Bjoern Mueller for reporting/testing this; ebuild cle... (diff)
downloadgentoo-2-07b3054068b82597e7c28dd61b6b896240ec2f69.tar.gz
gentoo-2-07b3054068b82597e7c28dd61b6b896240ec2f69.tar.bz2
gentoo-2-07b3054068b82597e7c28dd61b6b896240ec2f69.zip
This version runs etc-update and source's /etc/profile after a package remove to make sure the RUBYOPT variable gets cleared if it really needs to be
(Portage version: 2.1_pre7-r2)
Diffstat (limited to 'dev-ruby/rubygems/rubygems-0.8.11-r5.ebuild')
-rw-r--r--dev-ruby/rubygems/rubygems-0.8.11-r5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/rubygems/rubygems-0.8.11-r5.ebuild b/dev-ruby/rubygems/rubygems-0.8.11-r5.ebuild
new file mode 100644
index 000000000000..d34d44ce2d25
--- /dev/null
+++ b/dev-ruby/rubygems/rubygems-0.8.11-r5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rubygems/rubygems-0.8.11-r5.ebuild,v 1.1 2006/03/31 18:19:44 caleb Exp $
+
+inherit ruby
+
+DESCRIPTION="Centralized Ruby extension management system"
+HOMEPAGE="http://rubyforge.org/projects/rubygems/"
+LICENSE="Ruby"
+
+# The URL depends implicitly on the version, unfortunately. Even if you
+# change the filename on the end, it still downloads the same file.
+SRC_URI="http://rubyforge.org/frs/download.php/5207/${P}.tgz"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc-macos ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/ruby-1.8"
+
+PATCHES="${FILESDIR}/no_post_install.patch"
+USE_RUBY="ruby18"
+
+src_compile() {
+ return
+}
+
+src_install() {
+ ver=$(${RUBY} -r rbconfig -e 'print Config::CONFIG["MAJOR"] + "." + Config::CONFIG["MINOR"]')
+ GEM_HOME=${D}/usr/lib/ruby/gems/$ver ruby_src_install
+ cp ${FILESDIR}/auto_gem.rb ${D}/$(${RUBY} -r rbconfig -e 'print Config::CONFIG["sitedir"]')
+ keepdir /usr/lib/ruby/gems/$ver/doc
+ doenvd ${FILESDIR}/10rubygems
+}
+
+pkg_postinst()
+{
+ ewarn "If you have previously switched to using ruby18_with_gems using ruby-config, this"
+ ewarn "package has removed that file and makes it unnecessary anymore. Please use ruby-config"
+ ewarn "to revert back to ruby18."
+}
+
+pkg_postrm()
+{
+ # If we potentially downgraded, then getting rid of RUBYOPT from env.d is probably a smart idea.
+ env-update
+ source /etc/profile
+}