summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-21 20:53:22 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-21 20:53:22 +0000
commit6846af7050f71e8bb308ab0d1cf6991d5d983c3f (patch)
tree8f56c07ffd729c84dccc401920245caf92885ac5 /dev-ruby/ruby-termios
parentRemove unused file. (diff)
downloadgentoo-2-6846af7050f71e8bb308ab0d1cf6991d5d983c3f.tar.gz
gentoo-2-6846af7050f71e8bb308ab0d1cf6991d5d983c3f.tar.bz2
gentoo-2-6846af7050f71e8bb308ab0d1cf6991d5d983c3f.zip
Remove unused file. Remove examples USE flag, always install them (uncompressed), and die on tests' failure.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-termios')
-rw-r--r--dev-ruby/ruby-termios/ChangeLog7
-rw-r--r--dev-ruby/ruby-termios/files/ruby-termios-ruby19.patch87
-rw-r--r--dev-ruby/ruby-termios/ruby-termios-0.9.6-r1.ebuild10
3 files changed, 12 insertions, 92 deletions
diff --git a/dev-ruby/ruby-termios/ChangeLog b/dev-ruby/ruby-termios/ChangeLog
index 149744e796df..928a9dd40939 100644
--- a/dev-ruby/ruby-termios/ChangeLog
+++ b/dev-ruby/ruby-termios/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-termios
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-termios/ChangeLog,v 1.24 2010/07/05 19:00:11 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-termios/ChangeLog,v 1.25 2010/08/21 20:53:22 flameeyes Exp $
+
+ 21 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -files/ruby-termios-ruby19.patch, ruby-termios-0.9.6-r1.ebuild:
+ Remove unused file. Remove examples USE flag, always install them
+ (uncompressed), and die on tests' failure.
*ruby-termios-0.9.6-r1 (05 Jul 2010)
diff --git a/dev-ruby/ruby-termios/files/ruby-termios-ruby19.patch b/dev-ruby/ruby-termios/files/ruby-termios-ruby19.patch
deleted file mode 100644
index 97c631a986a6..000000000000
--- a/dev-ruby/ruby-termios/files/ruby-termios-ruby19.patch
+++ /dev/null
@@ -1,87 +0,0 @@
---- ruby-termios-0.9.4-/termios.c 2002-10-13 00:15:03.000000000 +0900
-+++ ruby-termios-0.9.4/termios.c 2005-05-27 16:53:32.000000000 +0900
-@@ -12,6 +12,12 @@
- #include <unistd.h>
- #include <string.h>
-
-+#ifdef GetReadFile
-+#define GetFD(fptr) fileno(GetReadFile(fptr))
-+#else
-+#define GetFD(fptr) (fptr->fd)
-+#endif
-+
- static VALUE mTermios;
- static VALUE cTermios;
- static VALUE tcsetattr_opt, tcflush_qs, tcflow_act;
-@@ -201,7 +207,7 @@
-
- Check_Type(io, T_FILE);
- GetOpenFile(io, fptr);
-- if (tcgetattr(fileno(fptr->f), &t) < 0) {
-+ if (tcgetattr(GetFD(fptr), &t) < 0) {
- rb_raise(rb_eRuntimeError,
- "can't get terminal parameters (%s)", strerror(errno));
- }
-@@ -243,7 +249,7 @@
- old = termios_tcgetattr(io);
- GetOpenFile(io, fptr);
- Termios_to_termios(param, &t);
-- if (tcsetattr(fileno(fptr->f), tcsetattr_option, &t) < 0) {
-+ if (tcsetattr(GetFD(fptr), tcsetattr_option, &t) < 0) {
- rb_raise(rb_eRuntimeError,
- "can't set terminal parameters (%s)", strerror(errno));
- }
-@@ -268,7 +274,7 @@
- Check_Type(duration, T_FIXNUM);
-
- GetOpenFile(io, fptr);
-- if (tcsendbreak(fileno(fptr->f), FIX2INT(duration)) < 0) {
-+ if (tcsendbreak(GetFD(fptr), FIX2INT(duration)) < 0) {
- rb_raise(rb_eRuntimeError,
- "can't transmits break (%s)", strerror(errno));
- }
-@@ -292,7 +298,7 @@
- Check_Type(io, T_FILE);
-
- GetOpenFile(io, fptr);
-- if (tcdrain(fileno(fptr->f)) < 0) {
-+ if (tcdrain(GetFD(fptr)) < 0) {
- rb_raise(rb_eRuntimeError, "can't drain (%s)", strerror(errno));
- }
-
-@@ -322,7 +328,7 @@
- }
-
- GetOpenFile(io, fptr);
-- if (tcflush(fileno(fptr->f), queue_selector) < 0) {
-+ if (tcflush(GetFD(fptr), queue_selector) < 0) {
- rb_raise(rb_eRuntimeError, "can't flush (%s)", strerror(errno));
- }
-
-@@ -352,7 +358,7 @@
- }
-
- GetOpenFile(io, fptr);
-- if (tcflow(fileno(fptr->f), action) < 0) {
-+ if (tcflow(GetFD(fptr), action) < 0) {
- rb_raise(rb_eRuntimeError,
- "can't control transmitting data flow (%s)", strerror(errno));
- }
-@@ -376,7 +382,7 @@
-
- Check_Type(io, T_FILE);
- GetOpenFile(io, fptr);
-- if ((pid = tcgetpgrp(fileno(fptr->f))) < 0) {
-+ if ((pid = tcgetpgrp(GetFD(fptr))) < 0) {
- rb_raise(rb_eRuntimeError,
- "can't get process group id (%s)", strerror(errno));
- }
-@@ -401,7 +407,7 @@
- Check_Type(pgrpid, T_FIXNUM);
-
- GetOpenFile(io, fptr);
-- if (tcsetpgrp(fileno(fptr->f), FIX2INT(pgrpid)) < 0) {
-+ if (tcsetpgrp(GetFD(fptr), FIX2INT(pgrpid)) < 0) {
- rb_raise(rb_eRuntimeError,
- "can't set process group id (%s)", strerror(errno));
- }
diff --git a/dev-ruby/ruby-termios/ruby-termios-0.9.6-r1.ebuild b/dev-ruby/ruby-termios/ruby-termios-0.9.6-r1.ebuild
index 7d6a53ed1ee9..d59b33736e88 100644
--- a/dev-ruby/ruby-termios/ruby-termios-0.9.6-r1.ebuild
+++ b/dev-ruby/ruby-termios/ruby-termios-0.9.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-termios/ruby-termios-0.9.6-r1.ebuild,v 1.1 2010/07/05 19:00:11 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-termios/ruby-termios-0.9.6-r1.ebuild,v 1.2 2010/08/21 20:53:22 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18"
@@ -13,7 +13,7 @@ SRC_URI="http://github.com/arika/ruby-termios/tarball/version_0_9_6 -> ${P}.tar.
LICENSE="Ruby"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
-IUSE="examples"
+IUSE=""
S="${WORKDIR}/arika-${PN}-94fd9ac"
@@ -26,7 +26,7 @@ each_ruby_compile() {
}
each_ruby_test() {
- ${RUBY} test/test0.rb
+ ${RUBY} test/test0.rb || die "tests failed"
}
each_ruby_install() {
@@ -35,5 +35,7 @@ each_ruby_install() {
all_ruby_install() {
dodoc ChangeLog README termios.rd
- use examples && docinto examples && dodoc examples/*
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/* || die
}