summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-05-09 11:45:49 +0000
committerTom William Payne <twp@gentoo.org>2003-05-09 11:45:49 +0000
commit1b1c5a95ed29f5db4af9a5f2aa1e23147eeb5c7b (patch)
treeae5810ea65d58cdaf6a6bd3b96586bca2d6e21a3 /dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild
parentInitial import (diff)
downloadgentoo-2-1b1c5a95ed29f5db4af9a5f2aa1e23147eeb5c7b.tar.gz
gentoo-2-1b1c5a95ed29f5db4af9a5f2aa1e23147eeb5c7b.tar.bz2
gentoo-2-1b1c5a95ed29f5db4af9a5f2aa1e23147eeb5c7b.zip
Initial import
Diffstat (limited to 'dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild')
-rw-r--r--dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild b/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild
new file mode 100644
index 000000000000..fb0f1f13fe18
--- /dev/null
+++ b/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ruby-postgres-0.7.1.ebuild,v 1.1 2003/05/09 11:45:31 twp Exp $
+
+DESCRIPTION="An extension library to access a PostgreSQL database from Ruby"
+HOMEPAGE="http://www.postgresql.jp/interfaces/ruby/"
+SRC_URI="http://www.postgresql.jp/interfaces/ruby/archive/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~ppc ~sparc ~x86"
+DEPEND=">=dev-lang/ruby-1.3.4
+ >=dev-db/postgresql-6.4"
+
+src_compile() {
+ ruby extconf.rb || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+}