summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-07-09 09:42:23 +0000
committerHans de Graaff <graaff@gentoo.org>2015-07-09 09:42:23 +0000
commitd37d1e21726286fd2d7f7124f85ae00e4c16b320 (patch)
tree791994cec770244e7eb641db42cf1166a8cbee22 /dev-ruby/ruby-gobject-introspection
parentRemove old. (diff)
downloadgentoo-2-d37d1e21726286fd2d7f7124f85ae00e4c16b320.tar.gz
gentoo-2-d37d1e21726286fd2d7f7124f85ae00e4c16b320.tar.bz2
gentoo-2-d37d1e21726286fd2d7f7124f85ae00e4c16b320.zip
Version bump. Run tests.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/ruby-gobject-introspection')
-rw-r--r--dev-ruby/ruby-gobject-introspection/ChangeLog8
-rw-r--r--dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-2.2.5.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/ruby-gobject-introspection/ChangeLog b/dev-ruby/ruby-gobject-introspection/ChangeLog
index 7d8edb8d216c..97506cfad2f2 100644
--- a/dev-ruby/ruby-gobject-introspection/ChangeLog
+++ b/dev-ruby/ruby-gobject-introspection/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-gobject-introspection
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gobject-introspection/ChangeLog,v 1.10 2015/07/06 09:40:28 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gobject-introspection/ChangeLog,v 1.11 2015/07/09 09:42:23 graaff Exp $
+
+*ruby-gobject-introspection-2.2.5 (09 Jul 2015)
+
+ 09 Jul 2015; Hans de Graaff <graaff@gentoo.org>
+ +ruby-gobject-introspection-2.2.5.ebuild:
+ Version bump. Run tests.
*ruby-gobject-introspection-2.2.3-r1 (06 Jul 2015)
diff --git a/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-2.2.5.ebuild b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-2.2.5.ebuild
new file mode 100644
index 000000000000..a29ad39a91d9
--- /dev/null
+++ b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-2.2.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-2.2.5.ebuild,v 1.1 2015/07/09 09:42:23 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+inherit ruby-ng-gnome2
+
+RUBY_S=ruby-gnome2-all-${PV}/gobject-introspection
+
+DESCRIPTION="Ruby GObjectIntrospection bindings"
+KEYWORDS="~amd64 ~ppc"
+IUSE=""
+
+DEPEND+=" dev-libs/gobject-introspection"
+RDEPEND+=" dev-libs/gobject-introspection"
+
+ruby_add_rdepend "~dev-ruby/ruby-glib2-${PV}"
+
+all_ruby_prepare() {
+ # Remove pregenerated Makefile since it will otherwise be shared by all targets.
+ rm -f Makefile Makefile.lib ext/gobject-introspection/Makefile || die
+
+ # Avoid unneeded dependency on test-unit-notify.
+ sed -i -e '/notify/ s:^:#:' test/gobject-introspection-test-utils.rb || die
+
+ # Avoid compilation of dependencies during test.
+ sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}