summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-04-13 18:33:46 +0000
committerHans de Graaff <graaff@gentoo.org>2015-04-13 18:33:46 +0000
commitf105d090be3373bd6031829588979922d4ee268d (patch)
tree6af89ef43de85f9961abb9ef1e1c5ee5f61d2292 /dev-ruby/rspec
parentVersion Bump (diff)
downloadgentoo-2-f105d090be3373bd6031829588979922d4ee268d.tar.gz
gentoo-2-f105d090be3373bd6031829588979922d4ee268d.tar.bz2
gentoo-2-f105d090be3373bd6031829588979922d4ee268d.zip
Create stable candidate.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rspec')
-rw-r--r--dev-ruby/rspec/ChangeLog8
-rw-r--r--dev-ruby/rspec/rspec-1.3.2-r1.ebuild6
-rw-r--r--dev-ruby/rspec/rspec-1.3.2-r2.ebuild79
3 files changed, 89 insertions, 4 deletions
diff --git a/dev-ruby/rspec/ChangeLog b/dev-ruby/rspec/ChangeLog
index ee26b987eb85..b06762cbe01a 100644
--- a/dev-ruby/rspec/ChangeLog
+++ b/dev-ruby/rspec/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.184 2015/02/21 09:38:49 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.185 2015/04/13 18:33:46 graaff Exp $
+
+*rspec-1.3.2-r2 (13 Apr 2015)
+
+ 13 Apr 2015; Hans de Graaff <graaff@gentoo.org> rspec-1.3.2-r1.ebuild,
+ +rspec-1.3.2-r2.ebuild:
+ Create stable candidate.
21 Feb 2015; Hans de Graaff <graaff@gentoo.org> rspec-2.99.0.ebuild,
rspec-3.2.0.ebuild:
diff --git a/dev-ruby/rspec/rspec-1.3.2-r1.ebuild b/dev-ruby/rspec/rspec-1.3.2-r1.ebuild
index e1d6e591ef1f..2e80d884ad7f 100644
--- a/dev-ruby/rspec/rspec-1.3.2-r1.ebuild
+++ b/dev-ruby/rspec/rspec-1.3.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-1.3.2-r1.ebuild,v 1.4 2014/12/07 15:22:57 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-1.3.2-r1.ebuild,v 1.5 2015/04/13 18:33:46 graaff Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_TASK_TEST="spec"
diff --git a/dev-ruby/rspec/rspec-1.3.2-r2.ebuild b/dev-ruby/rspec/rspec-1.3.2-r2.ebuild
new file mode 100644
index 000000000000..6b9e9fd54f99
--- /dev/null
+++ b/dev-ruby/rspec/rspec-1.3.2-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-1.3.2-r2.ebuild,v 1.1 2015/04/13 18:33:46 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc TODO.txt Ruby1.9.rdoc Upgrade.rdoc"
+
+RUBY_FAKEGEM_BINWRAP="spec"
+
+RUBY_FAKEGEM_GEMSPEC="rspec.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+# it's actually optional, but tests fail if it's not installed and
+# some other package might fail tests, so require it anyway.
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.2"
+
+RDEPEND="!<dev-ruby/rspec-rails-${PV}"
+
+# We should add nokogiri here to make sure that we test as much as
+# possible, but since it's yet unported to 1.9 and the nokogiri-due
+# tests fail for sure, we'll be waiting on it.
+ruby_add_bdepend "test? (
+ >=dev-ruby/hoe-2.0.0
+ dev-ruby/zentest
+ >=dev-ruby/syntax-1.0
+ >=dev-ruby/fakefs-0.2.1 )"
+ruby_add_bdepend "test? ( ~dev-ruby/test-unit-1.2.3 )"
+
+all_ruby_prepare() {
+ # Avoid dependency on git.
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Replace reference to /tmp to our temporary directory to avoid
+ # sandbox-related failure.
+ sed -i \
+ -e "s:/tmp:${T}:" \
+ spec/spec/runner/command_line_spec.rb || die
+
+ # Avoid unneeded dependency on bundler
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Avoid the formatter specs since they require output files for each
+ # ruby version and these are not present for any current ruby
+ # version.
+ rm spec/spec/runner/formatter/{html,text_mate}_formatter_spec.rb || die
+
+ # Drop heckle dependency.
+ rm spec/spec/runner/heckler_spec.rb spec/spec/runner/heckle_runner_spec.rb || die
+ sed -i -e '381,398 s:^:#:' spec/spec/runner/option_parser_spec.rb || die
+
+ # Avoid a spec that may fail on unimportant whitespace differences.
+ sed -e '/Diff in context format/,/^end/ s:^:#:' \
+ -i spec/spec/expectations/differs/default_spec.rb || die
+
+ # Remove broken spec.opts related tests. These were always broken
+ # because they don't set up state properly, but only with
+ # >=fakefs-0.4.2 this started throwing exceptions, bug 340385.
+ sed -i -e '/implicitly loading spec/,/^ end/ s:^:#:' spec/spec/runner/option_parser_spec.rb || die
+
+}
+
+src_test() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_test
+}