summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-25 17:35:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-12-25 17:35:15 +0000
commitf65f908664046962ace484ccc157913d93530fc7 (patch)
tree7d87abc389ae2098014ba58cf698b5038b664053 /dev-ruby/redcloth
parentAdd missing test and doc dependency over hoe (drop jruby support because of t... (diff)
downloadgentoo-2-f65f908664046962ace484ccc157913d93530fc7.tar.gz
gentoo-2-f65f908664046962ace484ccc157913d93530fc7.tar.bz2
gentoo-2-f65f908664046962ace484ccc157913d93530fc7.zip
Bump to ruby-fakegem, make sure that tests are executed.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/redcloth')
-rw-r--r--dev-ruby/redcloth/ChangeLog8
-rw-r--r--dev-ruby/redcloth/redcloth-4.2.2-r1.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-ruby/redcloth/ChangeLog b/dev-ruby/redcloth/ChangeLog
index 5455c131ba95..3c727277affe 100644
--- a/dev-ruby/redcloth/ChangeLog
+++ b/dev-ruby/redcloth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/redcloth
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.31 2009/12/09 20:53:40 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.32 2009/12/25 17:35:15 flameeyes Exp $
+
+*redcloth-4.2.2-r1 (25 Dec 2009)
+
+ 25 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +redcloth-4.2.2-r1.ebuild:
+ Bump to ruby-fakegem, make sure that tests are executed.
09 Dec 2009; Hans de Graaff <graaff@gentoo.org> -redcloth-3.0.4.ebuild,
-redcloth-4.2.1.ebuild:
diff --git a/dev-ruby/redcloth/redcloth-4.2.2-r1.ebuild b/dev-ruby/redcloth/redcloth-4.2.2-r1.ebuild
new file mode 100644
index 000000000000..c4eda810a34d
--- /dev/null
+++ b/dev-ruby/redcloth/redcloth-4.2.2-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.2-r1.ebuild,v 1.1 2009/12/25 17:35:15 flameeyes Exp $
+
+EAPI=2
+
+# jruby → should be supported, but since we don't have the Ragel files
+# in the tarball, we cannot generate the Java files (also nt
+# in the tarball).
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_NAME="RedCloth"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README CHANGELOG"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A module for using Textile in Ruby"
+HOMEPAGE="http://redcloth.org/"
+SRC_URI="mirror://rubyforge/redcloth/${RUBY_FAKEGEM_NAME}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}/${RUBY_FAKEGEM_NAME}-${PV}"
+
+ruby_add_bdepend '>=dev-ruby/echoe-3.0.1'
+
+ruby_add_bdepend test "dev-ruby/diff-lcs dev-ruby/rspec"
+
+all_ruby_prepare() {
+ sed -i \
+ -e 's|Platform|Echoe::Platform|' \
+ -e '/^# Ragel-generated/,/Optimization/ s:^:#:' \
+ -e '/task :spec/s|, :compile||' \
+ Rakefile || die "Rakefile fixes failed"
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die "build failed"
+}