summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-02-14 13:41:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-02-14 13:41:27 +0000
commite24f17f1375604f0615e81eef1f6eab1eb659a92 (patch)
treea3e2d3eaaed770ee1163a65f82a2e0e39f463ed3 /dev-ruby/rcov
parentVersion bump: EAPI4, reorder vars, initial support for LINGUAS, use 'dot' ins... (diff)
downloadgentoo-2-e24f17f1375604f0615e81eef1f6eab1eb659a92.tar.gz
gentoo-2-e24f17f1375604f0615e81eef1f6eab1eb659a92.tar.bz2
gentoo-2-e24f17f1375604f0615e81eef1f6eab1eb659a92.zip
Version bump; drop jruby support as it doesn't build with current JRuby and upstream is not very friendly.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rcov')
-rw-r--r--dev-ruby/rcov/ChangeLog9
-rw-r--r--dev-ruby/rcov/rcov-0.9.11.ebuild6
-rw-r--r--dev-ruby/rcov/rcov-0.9.9.ebuild6
-rw-r--r--dev-ruby/rcov/rcov-1.0.ebuild56
4 files changed, 70 insertions, 7 deletions
diff --git a/dev-ruby/rcov/ChangeLog b/dev-ruby/rcov/ChangeLog
index 96578cd2e961..4bfea5d4d6e8 100644
--- a/dev-ruby/rcov/ChangeLog
+++ b/dev-ruby/rcov/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/rcov
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/ChangeLog,v 1.20 2012/01/28 08:35:49 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/ChangeLog,v 1.21 2012/02/14 13:41:27 flameeyes Exp $
+
+*rcov-1.0 (14 Feb 2012)
+
+ 14 Feb 2012; Diego E. Pettenò <flameeyes@gentoo.org> +rcov-1.0.ebuild,
+ rcov-0.9.11.ebuild, rcov-0.9.9.ebuild:
+ Version bump; drop jruby support as it doesn't build with current JRuby and
+ upstream is not very friendly.
28 Jan 2012; Hans de Graaff <graaff@gentoo.org> -rcov-0.9.7.1.ebuild,
-rcov-0.9.8.ebuild:
diff --git a/dev-ruby/rcov/rcov-0.9.11.ebuild b/dev-ruby/rcov/rcov-0.9.11.ebuild
index bf59f9e430ac..0a0b745e6261 100644
--- a/dev-ruby/rcov/rcov-0.9.11.ebuild
+++ b/dev-ruby/rcov/rcov-0.9.11.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/rcov-0.9.11.ebuild,v 1.1 2011/10/10 19:49:09 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/rcov-0.9.11.ebuild,v 1.2 2012/02/14 13:41:27 flameeyes Exp $
EAPI=4
# The documenttion indicates that rcov does not work with (reliably)
# with ruby 1.9. Use ruby 1.9's built in coverage or simplecov instead.
-USE_RUBY="ruby18 jruby"
+USE_RUBY="ruby18 "
RUBY_FAKEGEM_TASK_TEST="test_rcovrt"
diff --git a/dev-ruby/rcov/rcov-0.9.9.ebuild b/dev-ruby/rcov/rcov-0.9.9.ebuild
index 6c037799490a..84d34cee5aa0 100644
--- a/dev-ruby/rcov/rcov-0.9.9.ebuild
+++ b/dev-ruby/rcov/rcov-0.9.9.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/rcov-0.9.9.ebuild,v 1.1 2010/09/19 09:27:23 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/rcov-0.9.9.ebuild,v 1.2 2012/02/14 13:41:27 flameeyes Exp $
EAPI=2
-USE_RUBY="ruby18 ruby19 jruby"
+USE_RUBY="ruby18 ruby19 "
RUBY_FAKEGEM_TASK_TEST="test_rcovrt"
diff --git a/dev-ruby/rcov/rcov-1.0.ebuild b/dev-ruby/rcov/rcov-1.0.ebuild
new file mode 100644
index 000000000000..b5ffdd85eee3
--- /dev/null
+++ b/dev-ruby/rcov/rcov-1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/rcov-1.0.ebuild,v 1.1 2012/02/14 13:41:27 flameeyes Exp $
+
+EAPI=4
+
+# The documenttion indicates that rcov does not work with (reliably)
+# with ruby 1.9. Use ruby 1.9's built in coverage or simplecov instead.
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="THANKS BLURB README.markdown"
+
+inherit ruby-fakegem versionator eutils
+
+DESCRIPTION="A ruby code coverage analysis tool"
+HOMEPAGE="http://eigenclass.org/hiki.rb?rcov"
+#SRC_URI="http://github.com/relevance/${PN}/tarball/release_$(replace_all_version_separators _) -> ${P}.tgz"
+SRC_URI="http://github.com/relevance/${PN}/tarball/e7c1821b50bef0f933ef857278bf82e9c24638e4 -> ${P}.tgz"
+
+RUBY_S="relevance-${PN}-*"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# TODO: both emacs and vim support are present in this package, they
+# should probably be added to the ebuild as well.
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+# upstream's Rakefile is braindead and just asking for rake -D causes
+# the extension to be rebuilt, so do everything by hand.
+
+each_ruby_configure() {
+ ${RUBY} -C ext/rcovrt extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -C ext/rcovrt CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp ext/rcovrt/*.so lib/ || die
+}
+
+all_ruby_compile() {
+ if use doc; then
+ rdoc --op rdoc || die
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb test/*_test.rb
+}