summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-06 18:32:18 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-06 18:32:18 +0000
commit2eae21e1551aa1ac374a0bb07b19e331311ba200 (patch)
tree1cb4a62ff567b1cacccfc123f2f9b8370eac4bba /dev-ruby/rcov
parentCleanup. (diff)
downloadgentoo-2-2eae21e1551aa1ac374a0bb07b19e331311ba200.tar.gz
gentoo-2-2eae21e1551aa1ac374a0bb07b19e331311ba200.tar.bz2
gentoo-2-2eae21e1551aa1ac374a0bb07b19e331311ba200.zip
Cleanup.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rcov')
-rw-r--r--dev-ruby/rcov/ChangeLog7
-rw-r--r--dev-ruby/rcov/rcov-0.9.11.ebuild57
2 files changed, 5 insertions, 59 deletions
diff --git a/dev-ruby/rcov/ChangeLog b/dev-ruby/rcov/ChangeLog
index 4e55d8a0d0cc..f33bc3b17ddc 100644
--- a/dev-ruby/rcov/ChangeLog
+++ b/dev-ruby/rcov/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/rcov
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/ChangeLog,v 1.22 2012/09/15 09:58:56 graaff Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/ChangeLog,v 1.23 2013/07/06 18:32:18 graaff Exp $
+
+ 06 Jul 2013; Hans de Graaff <graaff@gentoo.org> -rcov-0.9.11.ebuild:
+ Cleanup.
15 Sep 2012; Hans de Graaff <graaff@gentoo.org> -rcov-0.9.9.ebuild:
Cleanup.
diff --git a/dev-ruby/rcov/rcov-0.9.11.ebuild b/dev-ruby/rcov/rcov-0.9.11.ebuild
deleted file mode 100644
index 0a0b745e6261..000000000000
--- a/dev-ruby/rcov/rcov-0.9.11.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rcov/rcov-0.9.11.ebuild,v 1.2 2012/02/14 13:41:27 flameeyes Exp $
-
-EAPI=4
-
-# The documenttion indicates that rcov does not work with (reliably)
-# with ruby 1.9. Use ruby 1.9's built in coverage or simplecov instead.
-USE_RUBY="ruby18 "
-
-RUBY_FAKEGEM_TASK_TEST="test_rcovrt"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="THANKS BLURB"
-
-inherit ruby-fakegem versionator eutils
-
-DESCRIPTION="A ruby code coverage analysis tool"
-HOMEPAGE="http://eigenclass.org/hiki.rb?rcov"
-#SRC_URI="http://github.com/relevance/${PN}/tarball/release_$(replace_all_version_separators _) -> ${P}.tgz"
-SRC_URI="http://github.com/relevance/${PN}/tarball/b5513cae5ea3348d97c21a3c324d8e8a7768e814 -> ${P}.tgz"
-
-RUBY_S="relevance-${PN}-*"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-# TODO: both emacs and vim support are present in this package, they
-# should probably be added to the ebuild as well.
-IUSE=""
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-0.9.7.1-jruby.patch
-
- # Without this change, testing will always cause the extension to
- # be rebuilt, and we don't want that.
- sed -i -e '/:test_rcovrt =>/s| => \[.*\]||' Rakefile || die "Rakefile fix failed"
-
- # remove pre-packaged jar file (d'oh!)
- rm lib/rcovrt.jar || die
-
- # Remove test suite with failing tests that upstream believes to
- # work correctly so that we can run the remainder of tests.
- # https://github.com/relevance/rcov/issues/40
- rm test/code_coverage_analyzer_test.rb || die
-
-}
-
-each_ruby_compile() {
- if [[ $(basename ${RUBY}) = "jruby" ]]; then
- ${RUBY} -S rake lib/rcovrt.jar || die "build failed"
- else
- ${RUBY} -S rake ext/rcovrt/rcovrt.so || die "build failed"
- cp ext/rcovrt/rcovrt.so lib/ || die
- fi
-}