summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-22 14:34:22 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-22 14:34:22 +0000
commit46c0a8d226df0c1245adf3f1a80cb859346bff62 (patch)
tree1e6e3bded2209347737ef25025168b7c4f16b241 /dev-ruby/rails
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-46c0a8d226df0c1245adf3f1a80cb859346bff62.tar.gz
gentoo-2-46c0a8d226df0c1245adf3f1a80cb859346bff62.tar.bz2
gentoo-2-46c0a8d226df0c1245adf3f1a80cb859346bff62.zip
Remove old versions.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog6
-rw-r--r--dev-ruby/rails/rails-2.3.5-r2.ebuild80
-rw-r--r--dev-ruby/rails/rails-2.3.5-r3.ebuild80
-rw-r--r--dev-ruby/rails/rails-2.3.8.ebuild80
4 files changed, 5 insertions, 241 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 42a53c52f217..0d2b32e0b7a0 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.183 2011/01/12 16:33:18 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.184 2011/01/22 14:34:22 graaff Exp $
+
+ 22 Jan 2011; Hans de Graaff <graaff@gentoo.org> -rails-2.3.5-r2.ebuild,
+ -rails-2.3.5-r3.ebuild, -rails-2.3.8.ebuild:
+ Remove old versions.
12 Jan 2011; Hans de Graaff <graaff@gentoo.org> rails-3.0.3.ebuild:
Update dependency on eselect-rails to a version that understands Rails
diff --git a/dev-ruby/rails/rails-2.3.5-r2.ebuild b/dev-ruby/rails/rails-2.3.5-r2.ebuild
deleted file mode 100644
index 47b8c803c1db..000000000000
--- a/dev-ruby/rails/rails-2.3.5-r2.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.5-r2.ebuild,v 1.3 2010/05/22 14:36:13 flameeyes Exp $
-
-EAPI=2
-USE_RUBY="ruby18"
-
-RUBY_FAKEGEM_EXTRAINSTALL="builtin configs doc dispatches environments fresh_rakefile helpers html README"
-RUBY_FAKEGEM_EXTRADOC="README CHANGELOG"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-# gem lacks tests
-RUBY_FAKEGEM_TASK_TEST=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="ruby on rails is a web-application and persistance framework"
-HOMEPAGE="http://www.rubyonrails.org"
-
-LICENSE="MIT"
-SLOT="2.3"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-
-IUSE=""
-
-RDEPEND=">=app-admin/eselect-rails-0.15"
-
-ruby_add_rdepend ">=dev-ruby/rake-0.8.3
- ~dev-ruby/activerecord-${PV}
- ~dev-ruby/activeresource-${PV}
- ~dev-ruby/activesupport-${PV}
- ~dev-ruby/actionmailer-${PV}
- ~dev-ruby/actionpack-${PV}"
-ruby_add_bdepend "
- doc? ( dev-ruby/redcloth )
- test? ( dev-ruby/mocha )"
-
-all_ruby_prepare() {
- sed -i -e '/horo/d' Rakefile || die
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- # fails for missing template when using the gem distribution
- #if use doc; then
- # pushd guides
- # ruby rails_guides.rb || die "guide generation failed"
- # popd
- #fi
-}
-all_ruby_install() {
- all_fakegem_install
-
- ruby_fakegem_binwrapper rails rails-${PV}
-
- if use doc; then
- #pushd guides/output
- #docinto guides
- #dohtml -r *
- #popd
-
- pushd doc
- docinto api
- dohtml -r *
- popd
- fi
-}
-
-pkg_postinst() {
- elog "To select between slots of rails, use:"
- elog "\teselect rails"
-
- eselect rails update
-}
-
-pkg_postrm() {
- eselect rails update
-}
diff --git a/dev-ruby/rails/rails-2.3.5-r3.ebuild b/dev-ruby/rails/rails-2.3.5-r3.ebuild
deleted file mode 100644
index ec5f1945ccc9..000000000000
--- a/dev-ruby/rails/rails-2.3.5-r3.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.5-r3.ebuild,v 1.1 2010/05/23 11:03:14 a3li Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_EXTRAINSTALL="builtin configs doc dispatches environments fresh_rakefile helpers html README"
-RUBY_FAKEGEM_EXTRADOC="README CHANGELOG"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-# gem lacks tests
-RUBY_FAKEGEM_TASK_TEST=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="ruby on rails is a web-application and persistance framework"
-HOMEPAGE="http://www.rubyonrails.org"
-
-LICENSE="MIT"
-SLOT="2.3"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-
-IUSE=""
-
-RDEPEND=">=app-admin/eselect-rails-0.15"
-
-ruby_add_rdepend ">=dev-ruby/rake-0.8.3
- ~dev-ruby/activerecord-${PV} >=dev-ruby/activerecord-${PV}-r1
- ~dev-ruby/activeresource-${PV} >=dev-ruby/activeresource-${PV}-r1
- ~dev-ruby/activesupport-${PV} >=dev-ruby/activesupport-${PV}-r1
- ~dev-ruby/actionmailer-${PV} >=dev-ruby/actionmailer-${PV}-r1
- ~dev-ruby/actionpack-${PV} >=dev-ruby/actionpack-${PV}-r1"
-ruby_add_bdepend "
- doc? ( dev-ruby/redcloth )
- test? ( dev-ruby/mocha )"
-
-all_ruby_prepare() {
- sed -i -e '/horo/d' Rakefile || die
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- # fails for missing template when using the gem distribution
- #if use doc; then
- # pushd guides
- # ruby rails_guides.rb || die "guide generation failed"
- # popd
- #fi
-}
-all_ruby_install() {
- all_fakegem_install
-
- ruby_fakegem_binwrapper rails rails-${PV}
-
- if use doc; then
- #pushd guides/output
- #docinto guides
- #dohtml -r *
- #popd
-
- pushd doc
- docinto api
- dohtml -r *
- popd
- fi
-}
-
-pkg_postinst() {
- elog "To select between slots of rails, use:"
- elog "\teselect rails"
-
- eselect rails update
-}
-
-pkg_postrm() {
- eselect rails update
-}
diff --git a/dev-ruby/rails/rails-2.3.8.ebuild b/dev-ruby/rails/rails-2.3.8.ebuild
deleted file mode 100644
index 922caac36795..000000000000
--- a/dev-ruby/rails/rails-2.3.8.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.8.ebuild,v 1.3 2010/09/29 22:29:51 ranger Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_EXTRAINSTALL="builtin configs doc dispatches environments fresh_rakefile helpers html README"
-RUBY_FAKEGEM_EXTRADOC="README CHANGELOG"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-# gem lacks tests
-RUBY_FAKEGEM_TASK_TEST=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="ruby on rails is a web-application and persistance framework"
-HOMEPAGE="http://www.rubyonrails.org"
-
-LICENSE="MIT"
-SLOT="2.3"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-
-IUSE=""
-
-RDEPEND=">=app-admin/eselect-rails-0.15"
-
-ruby_add_rdepend ">=dev-ruby/rake-0.8.3
- ~dev-ruby/activerecord-${PV}
- ~dev-ruby/activeresource-${PV}
- ~dev-ruby/activesupport-${PV}
- ~dev-ruby/actionmailer-${PV}
- ~dev-ruby/actionpack-${PV}"
-ruby_add_bdepend "
- doc? ( dev-ruby/redcloth )
- test? ( dev-ruby/mocha )"
-
-all_ruby_prepare() {
- sed -i -e '/horo/d' Rakefile || die
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- # fails for missing template when using the gem distribution
- #if use doc; then
- # pushd guides
- # ruby rails_guides.rb || die "guide generation failed"
- # popd
- #fi
-}
-all_ruby_install() {
- all_fakegem_install
-
- ruby_fakegem_binwrapper rails rails-${PV}
-
- if use doc; then
- #pushd guides/output
- #docinto guides
- #dohtml -r *
- #popd
-
- pushd doc
- docinto api
- dohtml -r *
- popd
- fi
-}
-
-pkg_postinst() {
- elog "To select between slots of rails, use:"
- elog "\teselect rails"
-
- eselect rails update
-}
-
-pkg_postrm() {
- eselect rails update
-}