summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-11-25 11:42:26 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-11-25 11:42:26 +0000
commit55349c94f9911504bc314850367bb50e5ddfe620 (patch)
tree7e8ce111e9c5da6d052fe085a6fff6b83721fbd1 /dev-ruby/racc
parentDrop jruby target. (diff)
downloadgentoo-2-55349c94f9911504bc314850367bb50e5ddfe620.tar.gz
gentoo-2-55349c94f9911504bc314850367bb50e5ddfe620.tar.bz2
gentoo-2-55349c94f9911504bc314850367bb50e5ddfe620.zip
Drop jruby target.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/racc')
-rw-r--r--dev-ruby/racc/ChangeLog6
-rw-r--r--dev-ruby/racc/racc-1.4.11.ebuild33
-rw-r--r--dev-ruby/racc/racc-1.4.12.ebuild33
-rw-r--r--dev-ruby/racc/racc-1.4.9.ebuild41
4 files changed, 30 insertions, 83 deletions
diff --git a/dev-ruby/racc/ChangeLog b/dev-ruby/racc/ChangeLog
index 18ec1abea13d..8d86c8f5e448 100644
--- a/dev-ruby/racc/ChangeLog
+++ b/dev-ruby/racc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/racc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.112 2014/08/27 23:46:00 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.113 2014/11/25 11:42:26 mrueg Exp $
+
+ 25 Nov 2014; Manuel Rüger <mrueg@gentoo.org> racc-1.4.11.ebuild,
+ racc-1.4.12.ebuild, racc-1.4.9.ebuild:
+ Drop jruby target.
*racc-1.4.12 (27 Aug 2014)
diff --git a/dev-ruby/racc/racc-1.4.11.ebuild b/dev-ruby/racc/racc-1.4.11.ebuild
index dcbf77693a24..f0fde455979a 100644
--- a/dev-ruby/racc/racc-1.4.11.ebuild
+++ b/dev-ruby/racc/racc-1.4.11.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.11.ebuild,v 1.4 2014/05/26 05:26:44 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.11.ebuild,v 1.5 2014/11/25 11:42:26 mrueg Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 jruby"
+USE_RUBY="ruby19 ruby20 ruby21"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_TASK_DOC="docs"
@@ -41,32 +41,15 @@ all_ruby_prepare() {
}
each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- # Some tests are broken on jruby, avoid them. We used to
- # avoid all tests so this is not a regression for us.
- rm test/test_racc_command.rb || die
- ;;
- *)
- ${RUBY} -Cext/racc extconf.rb || die
- ;;
- esac
+ ${RUBY} -Cext/racc extconf.rb || die
}
each_ruby_compile() {
- case ${RUBY} in
- *jruby)
- einfo "Under JRuby, racc cannot use the shared object parser, so instead"
- einfo "you have to rely on the pure Ruby implementation."
- ;;
- *)
- emake V=1 -Cext/racc
- # Copy over the file here so that we don't have to do
- # special ruby install for JRuby and the other
- # implementations.
- cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
- ;;
- esac
+ emake V=1 -Cext/racc
+ # Copy over the file here so that we don't have to do
+ # special ruby install for JRuby and the other
+ # implementations.
+ cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
}
each_ruby_test() {
diff --git a/dev-ruby/racc/racc-1.4.12.ebuild b/dev-ruby/racc/racc-1.4.12.ebuild
index d7ba380a511d..f3bcfb28c3a0 100644
--- a/dev-ruby/racc/racc-1.4.12.ebuild
+++ b/dev-ruby/racc/racc-1.4.12.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.12.ebuild,v 1.1 2014/08/27 23:46:00 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.12.ebuild,v 1.2 2014/11/25 11:42:26 mrueg Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 jruby"
+USE_RUBY="ruby19 ruby20 ruby21"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_TASK_DOC="docs"
@@ -41,32 +41,15 @@ all_ruby_prepare() {
}
each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- # Some tests are broken on jruby, avoid them. We used to
- # avoid all tests so this is not a regression for us.
- rm test/test_racc_command.rb || die
- ;;
- *)
- ${RUBY} -Cext/racc extconf.rb || die
- ;;
- esac
+ ${RUBY} -Cext/racc extconf.rb || die
}
each_ruby_compile() {
- case ${RUBY} in
- *jruby)
- einfo "Under JRuby, racc cannot use the shared object parser, so instead"
- einfo "you have to rely on the pure Ruby implementation."
- ;;
- *)
- emake V=1 -Cext/racc
- # Copy over the file here so that we don't have to do
- # special ruby install for JRuby and the other
- # implementations.
- cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
- ;;
- esac
+ emake V=1 -Cext/racc
+ # Copy over the file here so that we don't have to do
+ # special ruby install for JRuby and the other
+ # implementations.
+ cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
}
each_ruby_test() {
diff --git a/dev-ruby/racc/racc-1.4.9.ebuild b/dev-ruby/racc/racc-1.4.9.ebuild
index 5d13bb9241f2..6175d22847dd 100644
--- a/dev-ruby/racc/racc-1.4.9.ebuild
+++ b/dev-ruby/racc/racc-1.4.9.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.9.ebuild,v 1.14 2014/04/24 16:39:32 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.9.ebuild,v 1.15 2014/11/25 11:42:26 mrueg Exp $
EAPI=4
-USE_RUBY="ruby19 ruby20 jruby"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_TASK_DOC="docs"
@@ -36,42 +36,19 @@ all_ruby_prepare() {
}
each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- ${RUBY} -Cext/racc extconf.rb || die
- ;;
- esac
+ ${RUBY} -Cext/racc extconf.rb || die
}
each_ruby_compile() {
- case ${RUBY} in
- *jruby)
- einfo "Under JRuby, racc cannot use the shared object parser, so instead"
- einfo "you have to rely on the pure Ruby implementation."
- ;;
- *)
- emake -Cext/racc
- # Copy over the file here so that we don't have to do
- # special ruby install for JRuby and the other
- # implementations.
- cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
- ;;
- esac
+ emake -Cext/racc
+ # Copy over the file here so that we don't have to do
+ # special ruby install for JRuby and the other
+ # implementations.
+ cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
}
each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ewarn "Using JRuby 1.5.2 the tests are currently badly broken,"
- ewarn "so they are disabled until a new racc or a new JRuby is"
- ewarn "released."
- ;;
- *)
- ${RUBY} -Ilib -S testrb test/test_*.rb || die
- ;;
- esac
+ ${RUBY} -Ilib -S testrb test/test_*.rb || die
}
all_ruby_install() {