summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-09-19 07:42:50 +0000
committerHans de Graaff <graaff@gentoo.org>2010-09-19 07:42:50 +0000
commit5a403e15d66461fadd602a51b91313fc97e629d4 (patch)
tree64b5ebe2434dfb6e4ddc8eb9aa881de14f635cd5 /dev-ruby/patron
parentclean old (diff)
downloadgentoo-2-5a403e15d66461fadd602a51b91313fc97e629d4.tar.gz
gentoo-2-5a403e15d66461fadd602a51b91313fc97e629d4.tar.bz2
gentoo-2-5a403e15d66461fadd602a51b91313fc97e629d4.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/patron')
-rw-r--r--dev-ruby/patron/ChangeLog7
-rw-r--r--dev-ruby/patron/patron-0.4.9.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ruby/patron/ChangeLog b/dev-ruby/patron/ChangeLog
index 76e1bdbc5a42..96dd66f9bd4d 100644
--- a/dev-ruby/patron/ChangeLog
+++ b/dev-ruby/patron/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/patron
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.2 2010/08/20 13:31:35 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.3 2010/09/19 07:42:50 graaff Exp $
+
+*patron-0.4.9 (19 Sep 2010)
+
+ 19 Sep 2010; Hans de Graaff <graaff@gentoo.org> +patron-0.4.9.ebuild:
+ Version bump.
*patron-0.4.6-r1 (20 Aug 2010)
diff --git a/dev-ruby/patron/patron-0.4.9.ebuild b/dev-ruby/patron/patron-0.4.9.ebuild
new file mode 100644
index 000000000000..6291d74ebf9b
--- /dev/null
+++ b/dev-ruby/patron/patron-0.4.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/patron-0.4.9.ebuild,v 1.1 2010/09/19 07:42:50 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl."
+HOMEPAGE="http://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/jeweler )"
+#ruby_add_bdepend "test? ( dev-ruby/jeweler dev-ruby/rspec )"
+
+DEPEND="${DEPEND} net-misc/curl"
+RDEPEND="${RDEPEND} net-misc/curl"
+
+# Tests require a live web service that is not included in the distribution.
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron || die
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}