summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-13 21:33:55 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-13 21:33:55 +0000
commit702de4039c49445f1e9a3f9801b371d382d9cd4d (patch)
tree5958dd3778a37650d11c24aedd1167154f6364e1 /dev-ruby/ohai
parentFix mask on all revisions. (diff)
downloadgentoo-2-702de4039c49445f1e9a3f9801b371d382d9cd4d.tar.gz
gentoo-2-702de4039c49445f1e9a3f9801b371d382d9cd4d.tar.bz2
gentoo-2-702de4039c49445f1e9a3f9801b371d382d9cd4d.zip
Revision bump to remove the patch that does not work; drop ruby19 support as tests blatantly fail expecting Ruby 1.8 instead.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ohai')
-rw-r--r--dev-ruby/ohai/ChangeLog11
-rw-r--r--dev-ruby/ohai/files/ohai-6.14.0-multiple-ruby.patch17
-rw-r--r--dev-ruby/ohai/ohai-0.6.12.ebuild4
-rw-r--r--dev-ruby/ohai/ohai-6.14.0-r1.ebuild (renamed from dev-ruby/ohai/ohai-6.14.0.ebuild)10
4 files changed, 14 insertions, 28 deletions
diff --git a/dev-ruby/ohai/ChangeLog b/dev-ruby/ohai/ChangeLog
index abb9d7a7f771..3bc7776690db 100644
--- a/dev-ruby/ohai/ChangeLog
+++ b/dev-ruby/ohai/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/ohai
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ChangeLog,v 1.13 2012/08/11 16:17:12 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ChangeLog,v 1.14 2012/08/13 21:33:55 flameeyes Exp $
+
+*ohai-6.14.0-r1 (13 Aug 2012)
+
+ 13 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> +ohai-6.14.0-r1.ebuild,
+ -files/ohai-6.14.0-multiple-ruby.patch, -ohai-6.14.0.ebuild,
+ ohai-0.6.12.ebuild:
+ Revision bump to remove the patch that does not work; drop ruby19 support as
+ tests blatantly fail expecting Ruby 1.8 instead.
11 Aug 2012; Benedikt Böhm <hollow@gentoo.org> ohai-0.6.12.ebuild:
add ruby19 support
@@ -66,4 +74,3 @@
03 Jul 2010; Benedikt Böhm <hollow@gentoo.org> +ohai-0.5.6.ebuild,
+files/ohai-lsb-release.patch, +metadata.xml:
initial ebuild, thanks to Gábor Vészi
-
diff --git a/dev-ruby/ohai/files/ohai-6.14.0-multiple-ruby.patch b/dev-ruby/ohai/files/ohai-6.14.0-multiple-ruby.patch
deleted file mode 100644
index 6b69d4f85253..000000000000
--- a/dev-ruby/ohai/files/ohai-6.14.0-multiple-ruby.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/lib/ohai/plugins/ruby.rb b/lib/ohai/plugins/ruby.rb
-index a54de8e..67591d0 100644
---- a/lib/ohai/plugins/ruby.rb
-+++ b/lib/ohai/plugins/ruby.rb
-@@ -20,9 +20,11 @@ provides "languages/ruby"
-
- require_plugin "languages"
-
-+require 'rbconfig'
-
- def run_ruby(command)
-- cmd = "ruby -e \"require 'rbconfig'; #{command}\""
-+ ruby = ::File.join(::RbConfig::CONFIG['bindir'], ::RbConfig::CONFIG['ruby_install_name'])
-+ cmd = %{#{ruby} -e "require 'rbconfig'; #{command}"}
- status, stdout, stderr = run_command(:no_status_check => true, :command => cmd)
- stdout.strip
- end
diff --git a/dev-ruby/ohai/ohai-0.6.12.ebuild b/dev-ruby/ohai/ohai-0.6.12.ebuild
index f073f9bda597..947be7a17bd3 100644
--- a/dev-ruby/ohai/ohai-0.6.12.ebuild
+++ b/dev-ruby/ohai/ohai-0.6.12.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ohai-0.6.12.ebuild,v 1.2 2012/08/11 16:17:12 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ohai-0.6.12.ebuild,v 1.3 2012/08/13 21:33:55 flameeyes Exp $
EAPI=4
-USE_RUBY="ruby18 ruby19"
+USE_RUBY="ruby18"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
diff --git a/dev-ruby/ohai/ohai-6.14.0.ebuild b/dev-ruby/ohai/ohai-6.14.0-r1.ebuild
index c387271735fe..e791532db10d 100644
--- a/dev-ruby/ohai/ohai-6.14.0.ebuild
+++ b/dev-ruby/ohai/ohai-6.14.0-r1.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ohai-6.14.0.ebuild,v 1.1 2012/08/11 09:14:47 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ohai-6.14.0-r1.ebuild,v 1.1 2012/08/13 21:33:55 flameeyes Exp $
EAPI=4
-USE_RUBY="ruby18 ruby19"
+USE_RUBY="ruby18"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
-RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
inherit ruby-fakegem
@@ -22,10 +22,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RUBY_PATCHES=( "${FILESDIR}/ohai-6.14.0-multiple-ruby.patch" )
-
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
-
ruby_add_rdepend "
dev-ruby/ipaddress
dev-ruby/mixlib-cli