summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-20 12:03:40 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-20 12:03:40 +0000
commite7b2eba8ccbe1788ff2b91eb28aa67bcd5662d4d (patch)
tree7e0f7fca399853357f0670f9d8505e2242814927 /dev-ruby/nokogiri
parent[bump] dev-perl/POE-1.310.0 (diff)
downloadgentoo-2-e7b2eba8ccbe1788ff2b91eb28aa67bcd5662d4d.tar.gz
gentoo-2-e7b2eba8ccbe1788ff2b91eb28aa67bcd5662d4d.tar.bz2
gentoo-2-e7b2eba8ccbe1788ff2b91eb28aa67bcd5662d4d.zip
Fix tests with libxml 2.8.7 with upstream patch.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/nokogiri')
-rw-r--r--dev-ruby/nokogiri/ChangeLog6
-rw-r--r--dev-ruby/nokogiri/files/nokogiri-1.4.4-libxml-2.7.8.patch19
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.4.4.ebuild4
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-ruby/nokogiri/ChangeLog b/dev-ruby/nokogiri/ChangeLog
index a4a615240b86..7206eefdc9bb 100644
--- a/dev-ruby/nokogiri/ChangeLog
+++ b/dev-ruby/nokogiri/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/nokogiri
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.49 2011/02/16 07:27:18 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.50 2011/04/20 12:03:40 graaff Exp $
+
+ 20 Apr 2011; Hans de Graaff <graaff@gentoo.org> nokogiri-1.4.4.ebuild,
+ +files/nokogiri-1.4.4-libxml-2.7.8.patch:
+ Fix tests with libxml 2.8.7 with upstream patch.
16 Feb 2011; Hans de Graaff <graaff@gentoo.org> -nokogiri-1.4.1-r1.ebuild,
-nokogiri-1.4.3.1.ebuild, -nokogiri-1.4.3.1-r1.ebuild:
diff --git a/dev-ruby/nokogiri/files/nokogiri-1.4.4-libxml-2.7.8.patch b/dev-ruby/nokogiri/files/nokogiri-1.4.4-libxml-2.7.8.patch
new file mode 100644
index 000000000000..ba472d30a376
--- /dev/null
+++ b/dev-ruby/nokogiri/files/nokogiri-1.4.4-libxml-2.7.8.patch
@@ -0,0 +1,19 @@
+commit abe249425bef0356f54408b89c9f376c62862e87
+Author: Mike Dalessio <mike@csa.net>
+Date: Wed Dec 8 10:23:52 2010 -0500
+
+ hey now. this test was failing for LIBXML > 2.7.7. sigh.
+
+diff --git a/test/html/test_element_description.rb b/test/html/test_element_description.rb
+index 2111cde..cfa9ca6 100644
+--- a/test/html/test_element_description.rb
++++ b/test/html/test_element_description.rb
+@@ -56,7 +56,7 @@ module Nokogiri
+
+ def test_subelements
+ sub_elements = ElementDescription['body'].sub_elements
+- if Nokogiri::LIBXML_VERSION == '2.7.7'
++ if Nokogiri::LIBXML_VERSION >= '2.7.7'
+ assert_equal 65, sub_elements.length
+ else
+ assert_equal 61, sub_elements.length
diff --git a/dev-ruby/nokogiri/nokogiri-1.4.4.ebuild b/dev-ruby/nokogiri/nokogiri-1.4.4.ebuild
index 6af9faf9647e..93ae2e78e3cc 100644
--- a/dev-ruby/nokogiri/nokogiri-1.4.4.ebuild
+++ b/dev-ruby/nokogiri/nokogiri-1.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.4.4.ebuild,v 1.5 2011/02/02 13:34:39 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.4.4.ebuild,v 1.6 2011/04/20 12:03:40 graaff Exp $
EAPI=2
@@ -43,6 +43,8 @@ ruby_add_rdepend "ffi? ( virtual/ruby-ffi )"
# ruby_add_bdepend "test? ( dev-ruby/weakling )"
all_ruby_prepare() {
+ epatch "${FILESDIR}/${P}-libxml-2.7.8.patch"
+
sed -i \
-e '/tasks\/cross_compile/s:^:#:' \
-e '/:test.*prerequisites/s:^:#:' \