summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-09 12:47:46 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-09 12:47:46 +0000
commit0ce379d07e7728da1510a01b5b580e890cc690cf (patch)
tree30a16f44856f91957e5107491793adf37cdcb594 /dev-ruby/multi_xml
parentVersion bump. (diff)
downloadgentoo-2-0ce379d07e7728da1510a01b5b580e890cc690cf.tar.gz
gentoo-2-0ce379d07e7728da1510a01b5b580e890cc690cf.tar.bz2
gentoo-2-0ce379d07e7728da1510a01b5b580e890cc690cf.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/multi_xml')
-rw-r--r--dev-ruby/multi_xml/ChangeLog9
-rw-r--r--dev-ruby/multi_xml/multi_xml-0.4.2.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-ruby/multi_xml/ChangeLog b/dev-ruby/multi_xml/ChangeLog
index 1826da56ac45..7f7b205f142e 100644
--- a/dev-ruby/multi_xml/ChangeLog
+++ b/dev-ruby/multi_xml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/multi_xml
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_xml/ChangeLog,v 1.6 2011/12/28 12:02:08 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_xml/ChangeLog,v 1.7 2012/04/09 12:47:46 graaff Exp $
+
+*multi_xml-0.4.2 (09 Apr 2012)
+
+ 09 Apr 2012; Hans de Graaff <graaff@gentoo.org> +multi_xml-0.4.2.ebuild:
+ Version bump.
28 Dec 2011; Hans de Graaff <graaff@gentoo.org> multi_xml-0.4.1.ebuild:
Add back jruby support as well.
diff --git a/dev-ruby/multi_xml/multi_xml-0.4.2.ebuild b/dev-ruby/multi_xml/multi_xml-0.4.2.ebuild
new file mode 100644
index 000000000000..2d84bbc0f1a0
--- /dev/null
+++ b/dev-ruby/multi_xml/multi_xml-0.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_xml/multi_xml-0.4.2.ebuild,v 1.1 2012/04/09 12:47:46 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generic swappable back-end for XML parsing"
+HOMEPAGE="http://rdoc.info/gems/multi_xml"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5:2 )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile spec/helper.rb || die
+ sed -i -e '/[Ss]imple[Cc]ov/d' spec/helper.rb || die
+
+ # Remove possible incompatible rspec options.
+ rm .rspec || die
+}