summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-05-10 14:19:37 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-05-10 14:19:37 +0000
commite89e1c8729c411e5d05f04ca7781ad6be511390b (patch)
tree224df95d8bd197a4e45ce966910cbe96f293b382 /dev-ruby/msgpack
parentVersion bumped. Added static-libs USE flag. (diff)
downloadgentoo-2-e89e1c8729c411e5d05f04ca7781ad6be511390b.tar.gz
gentoo-2-e89e1c8729c411e5d05f04ca7781ad6be511390b.tar.bz2
gentoo-2-e89e1c8729c411e5d05f04ca7781ad6be511390b.zip
Version bumped. Added ruby19 to USE_RUBY.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/msgpack')
-rw-r--r--dev-ruby/msgpack/ChangeLog9
-rw-r--r--dev-ruby/msgpack/msgpack-0.4.5.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-ruby/msgpack/ChangeLog b/dev-ruby/msgpack/ChangeLog
index 89a560732578..6dbd457da2eb 100644
--- a/dev-ruby/msgpack/ChangeLog
+++ b/dev-ruby/msgpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/msgpack
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/ChangeLog,v 1.9 2010/12/31 22:41:00 graaff Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/ChangeLog,v 1.10 2011/05/10 14:19:37 matsuu Exp $
+
+*msgpack-0.4.5 (10 May 2011)
+
+ 10 May 2011; MATSUU Takuto <matsuu@gentoo.org> +msgpack-0.4.5.ebuild:
+ Version bumped. Added ruby19 to USE_RUBY.
*msgpack-0.4.4 (31 Dec 2010)
diff --git a/dev-ruby/msgpack/msgpack-0.4.5.ebuild b/dev-ruby/msgpack/msgpack-0.4.5.ebuild
new file mode 100644
index 000000000000..91b7f5a8ac5a
--- /dev/null
+++ b/dev-ruby/msgpack/msgpack-0.4.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/msgpack-0.4.5.ebuild,v 1.1 2011/05/10 14:19:37 matsuu Exp $
+
+EAPI="3"
+
+# ruby19 → tests fail
+# jruby → uses a binary extension
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
+HOMEPAGE="http://msgpack.sourceforge.jp/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die "Configuration of extension failed."
+}
+
+each_ruby_compile() {
+ emake -Cext || die
+
+ mkdir lib || die "Unable to make lib directory."
+ cp ext/msgpack.so lib/ || die "Unable to install msgpack library."
+}
+
+each_ruby_test() {
+ cd test
+ ${RUBY} test_cases.rb || die "tests failed"
+ ${RUBY} test_pack_unpack.rb || die "tests failed"
+}