summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-12 06:06:02 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-12 06:06:02 +0000
commit0466f2a51bdcc89a024e07c8241b42eaf0effccf (patch)
treed181a154db12c76d4e9dcb009a25b84372b15ad1 /dev-ruby/mongo
parentDo not build doc unconditionally, restore USE=doc. (diff)
downloadgentoo-2-0466f2a51bdcc89a024e07c8241b42eaf0effccf.tar.gz
gentoo-2-0466f2a51bdcc89a024e07c8241b42eaf0effccf.tar.bz2
gentoo-2-0466f2a51bdcc89a024e07c8241b42eaf0effccf.zip
Remove old.
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/mongo')
-rw-r--r--dev-ruby/mongo/ChangeLog6
-rw-r--r--dev-ruby/mongo/mongo-1.5.2.ebuild46
-rw-r--r--dev-ruby/mongo/mongo-1.6.0.ebuild46
-rw-r--r--dev-ruby/mongo/mongo-1.6.1.ebuild46
4 files changed, 5 insertions, 139 deletions
diff --git a/dev-ruby/mongo/ChangeLog b/dev-ruby/mongo/ChangeLog
index 61944e1ec734..ae111e3a6315 100644
--- a/dev-ruby/mongo/ChangeLog
+++ b/dev-ruby/mongo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/mongo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongo/ChangeLog,v 1.5 2012/05/11 04:13:02 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongo/ChangeLog,v 1.6 2012/05/12 06:06:02 flameeyes Exp $
+
+ 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org> -mongo-1.5.2.ebuild,
+ -mongo-1.6.0.ebuild, -mongo-1.6.1.ebuild:
+ Remove old.
11 May 2012; Diego E. Pettenò <flameeyes@gentoo.org> mongo-1.6.2.ebuild:
Add support for ruby 1.9 (works fine).
diff --git a/dev-ruby/mongo/mongo-1.5.2.ebuild b/dev-ruby/mongo/mongo-1.5.2.ebuild
deleted file mode 100644
index 309654cb9fa9..000000000000
--- a/dev-ruby/mongo/mongo-1.5.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongo/mongo-1.5.2.ebuild,v 1.1 2011/12/28 23:56:06 flameeyes Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_TEST="test:unit"
-
-RUBY_FAKEGEM_TASK_DOC="rdoc"
-RUBY_FAKEGEM_DOCDIR="html"
-RUBY_FAKEGEM_EXTRADOC=""
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-GITHUB_USER="mongodb"
-GITHUB_PROJECT="mongo-ruby-driver"
-RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Ruby driver for MongoDB."
-HOMEPAGE="http://www.mongodb.org/"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/tarball/${PV} -> ${GITHUB_PROJECT}-${PV}.tar.gz"
-
-LICENSE="APSL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-# This is the same source package as bson, so keep them the same
-# version, but not revision
-ruby_add_rdepend "~dev-ruby/bson-${PV}"
-
-ruby_add_bdepend \
- "test? (
- dev-ruby/rake
- dev-ruby/shoulda
- dev-ruby/mocha
- )"
-
-all_ruby_prepare() {
- # remove the stuff that is actually part of dev-ruby/bson
- rm -rf lib/bson* bin/{b2j,j2b}son
-}
diff --git a/dev-ruby/mongo/mongo-1.6.0.ebuild b/dev-ruby/mongo/mongo-1.6.0.ebuild
deleted file mode 100644
index d044d3bee894..000000000000
--- a/dev-ruby/mongo/mongo-1.6.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongo/mongo-1.6.0.ebuild,v 1.1 2012/02/22 23:56:16 flameeyes Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_TEST="test:unit"
-
-RUBY_FAKEGEM_TASK_DOC="rdoc"
-RUBY_FAKEGEM_DOCDIR="html"
-RUBY_FAKEGEM_EXTRADOC=""
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-GITHUB_USER="mongodb"
-GITHUB_PROJECT="mongo-ruby-driver"
-RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Ruby driver for MongoDB."
-HOMEPAGE="http://www.mongodb.org/"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/tarball/${PV} -> ${GITHUB_PROJECT}-${PV}.tar.gz"
-
-LICENSE="APSL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-# This is the same source package as bson, so keep them the same
-# version, but not revision
-ruby_add_rdepend "~dev-ruby/bson-${PV}"
-
-ruby_add_bdepend \
- "test? (
- dev-ruby/rake
- dev-ruby/shoulda
- dev-ruby/mocha
- )"
-
-all_ruby_prepare() {
- # remove the stuff that is actually part of dev-ruby/bson
- rm -rf lib/bson* bin/{b2j,j2b}son
-}
diff --git a/dev-ruby/mongo/mongo-1.6.1.ebuild b/dev-ruby/mongo/mongo-1.6.1.ebuild
deleted file mode 100644
index dc46b8952c21..000000000000
--- a/dev-ruby/mongo/mongo-1.6.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongo/mongo-1.6.1.ebuild,v 1.1 2012/03/08 01:31:45 flameeyes Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_TEST="test:unit"
-
-RUBY_FAKEGEM_TASK_DOC="rdoc"
-RUBY_FAKEGEM_DOCDIR="html"
-RUBY_FAKEGEM_EXTRADOC=""
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-GITHUB_USER="mongodb"
-GITHUB_PROJECT="mongo-ruby-driver"
-RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Ruby driver for MongoDB."
-HOMEPAGE="http://www.mongodb.org/"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/tarball/${PV} -> ${GITHUB_PROJECT}-${PV}.tar.gz"
-
-LICENSE="APSL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-# This is the same source package as bson, so keep them the same
-# version, but not revision
-ruby_add_rdepend "~dev-ruby/bson-${PV}"
-
-ruby_add_bdepend \
- "test? (
- dev-ruby/rake
- dev-ruby/shoulda
- dev-ruby/mocha
- )"
-
-all_ruby_prepare() {
- # remove the stuff that is actually part of dev-ruby/bson
- rm -rf lib/bson* bin/{b2j,j2b}son
-}