summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-08 12:32:38 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-08 12:32:38 +0000
commit495e2c36e3d01891eeb6b3340733a4213ad42028 (patch)
treee897615c2462410a64d1978c1c6ab472a7e22df0 /dev-ruby/mixlib-shellout
parentRemove mask on x11-plugins/msn-pecan and x11-plugins/pidgin-facebookchat afte... (diff)
downloadgentoo-2-495e2c36e3d01891eeb6b3340733a4213ad42028.tar.gz
gentoo-2-495e2c36e3d01891eeb6b3340733a4213ad42028.tar.bz2
gentoo-2-495e2c36e3d01891eeb6b3340733a4213ad42028.zip
Version bump.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/mixlib-shellout')
-rw-r--r--dev-ruby/mixlib-shellout/ChangeLog7
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-1.6.0.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-ruby/mixlib-shellout/ChangeLog b/dev-ruby/mixlib-shellout/ChangeLog
index 4b2a71ef7ef4..066a4e89cefa 100644
--- a/dev-ruby/mixlib-shellout/ChangeLog
+++ b/dev-ruby/mixlib-shellout/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/mixlib-shellout
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/ChangeLog,v 1.9 2014/07/22 06:04:59 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/ChangeLog,v 1.10 2014/10/08 12:32:38 mrueg Exp $
+
+*mixlib-shellout-1.6.0 (08 Oct 2014)
+
+ 08 Oct 2014; Manuel Rüger <mrueg@gentoo.org> +mixlib-shellout-1.6.0.ebuild:
+ Version bump.
*mixlib-shellout-1.4.0 (22 Jul 2014)
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-1.6.0.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-1.6.0.ebuild
new file mode 100644
index 000000000000..187594768221
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-1.6.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mixlib-shellout/mixlib-shellout-1.6.0.ebuild,v 1.1 2014/10/08 12:32:38 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRA_DOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="http://github.com/opscode/mixlib-shellout"
+SRC_URI="https://github.com/opscode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+}