summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-11-26 02:21:34 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-11-26 02:21:34 +0000
commita40e8f20362864975dc356afaa1cbd7989387bcf (patch)
treed9e9c9b1b5e8166270f11b08b176ea7e5a809b29 /dev-ruby/map
parentDrop jruby target. (diff)
downloadgentoo-2-a40e8f20362864975dc356afaa1cbd7989387bcf.tar.gz
gentoo-2-a40e8f20362864975dc356afaa1cbd7989387bcf.tar.bz2
gentoo-2-a40e8f20362864975dc356afaa1cbd7989387bcf.zip
Drop jruby traces.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/map')
-rw-r--r--dev-ruby/map/ChangeLog7
-rw-r--r--dev-ruby/map/files/map-6.5.1-ruby18-failing-tests.patch75
-rw-r--r--dev-ruby/map/map-6.5.4.ebuild12
-rw-r--r--dev-ruby/map/map-6.5.5.ebuild12
4 files changed, 8 insertions, 98 deletions
diff --git a/dev-ruby/map/ChangeLog b/dev-ruby/map/ChangeLog
index ad2a0fc957e1..f74d8e7d1d9d 100644
--- a/dev-ruby/map/ChangeLog
+++ b/dev-ruby/map/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/map
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/ChangeLog,v 1.18 2014/09/12 12:25:49 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/ChangeLog,v 1.19 2014/11/26 02:21:34 mrueg Exp $
+
+ 26 Nov 2014; Manuel Rüger <mrueg@gentoo.org>
+ -files/map-6.5.1-ruby18-failing-tests.patch, map-6.5.4.ebuild,
+ map-6.5.5.ebuild:
+ Drop jruby traces.
*map-6.5.5 (12 Sep 2014)
diff --git a/dev-ruby/map/files/map-6.5.1-ruby18-failing-tests.patch b/dev-ruby/map/files/map-6.5.1-ruby18-failing-tests.patch
deleted file mode 100644
index d33a5fa0fbe2..000000000000
--- a/dev-ruby/map/files/map-6.5.1-ruby18-failing-tests.patch
+++ /dev/null
@@ -1,75 +0,0 @@
---- test/map_test.rb.old 2013-10-14 17:23:08.612541725 +0100
-+++ test/map_test.rb 2013-10-14 17:24:20.001644242 +0100
-@@ -405,47 +405,6 @@
- assert{ m[:key][0].is_a?(Map) }
- end
-
-- testing 'that #add overlays the leaves of one hash onto another without nuking branches' do
-- m = Map.new
--
-- assert do
-- m.add(
-- :comments => [
-- { :body => 'a' },
-- { :body => 'b' },
-- ],
--
-- [:comments, 0] => {'title' => 'teh title', 'description' => 'description'},
-- [:comments, 1] => {'description' => 'description'},
-- )
-- end
--
-- assert do
-- m =~
-- {"comments"=>
-- [{"body"=>"a", "title"=>"teh title", "description"=>"description"},
-- {"body"=>"b", "description"=>"description"}]}
-- end
--
-- m = Map.new
--
-- assert do
-- m.add(
-- [:a, :b, :c] => 42,
--
-- [:a, :b] => {:d => 42.0}
-- )
-- end
--
-- assert do
-- m =~
-- {"a"=>{"b"=>{"c"=>42, "d"=>42.0}}}
-- end
--
-- assert{ Map.new.tap{|i| i.add} =~ {} }
-- assert{ Map.new.tap{|i| i.add({})} =~ {} }
-- end
--
- testing 'that Map.combine is teh sweet' do
- {
- [{:a => {:b => 42}}, {:a => {:c => 42.0}}] =>
-@@ -734,24 +693,6 @@
- assert{ map.list.class != Array }
- end
-
-- testing 'rack compatible params' do
-- m = Map.for(:a => [{}, {:b => 42}], :x => [ nil, [ nil, {:y => 42}] ], :A => {:B => {:C => 42}})
--
-- assert{ m.param_for(:a, 1, :b) == 'map[a][][b]=42' }
-- assert{ m.name_for(:a, 1, :b) == 'map[a][][b]' }
--
-- assert{ m.param_for(:x, 1, 1, :y) == 'map[x][][][y]=42' }
-- assert{ m.name_for(:x, 1, 1, :y) == 'map[x][][][y]' }
--
-- assert{ m.param_for(:A, :B, :C) == 'map[A][B][C]=42' }
-- assert{ m.name_for(:A, :B, :C) == 'map[A][B][C]' }
--
-- assert{ m.name_for(:A, :B, :C, :prefix => :foo) == 'foo[A][B][C]' }
--
-- m = Map.for({"a"=>{"b"=>42}, "x"=>{"y"=>42}, "foo"=>:bar, "array"=>[{"k"=>:v}]})
-- assert{ m.to_params == "map[a][b]=42&map[x][y]=42&map[foo]=bar&map[array][][k]=v" }
-- end
--
- testing 'delete_if' do
- m = Map.for(:k => :v)
- assert{ m.delete_if{|k| k.to_s == 'k'} }
diff --git a/dev-ruby/map/map-6.5.4.ebuild b/dev-ruby/map/map-6.5.4.ebuild
index a747f5fdfadd..cb8297ba0c6c 100644
--- a/dev-ruby/map/map-6.5.4.ebuild
+++ b/dev-ruby/map/map-6.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/map-6.5.4.ebuild,v 1.2 2014/08/05 16:00:56 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/map-6.5.4.ebuild,v 1.3 2014/11/26 02:21:34 mrueg Exp $
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21"
@@ -20,13 +20,3 @@ LICENSE="|| ( Ruby BSD-2 )"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
IUSE=""
-
-each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- epatch "${FILESDIR}/${PN}-6.5.1-ruby18-failing-tests.patch"
- ;;
- *)
- ;;
- esac
-}
diff --git a/dev-ruby/map/map-6.5.5.ebuild b/dev-ruby/map/map-6.5.5.ebuild
index 862cb6deb445..20e0ef4f9dfc 100644
--- a/dev-ruby/map/map-6.5.5.ebuild
+++ b/dev-ruby/map/map-6.5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/map-6.5.5.ebuild,v 1.1 2014/09/12 12:25:49 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/map/map-6.5.5.ebuild,v 1.2 2014/11/26 02:21:34 mrueg Exp $
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21"
@@ -20,13 +20,3 @@ LICENSE="|| ( Ruby BSD-2 )"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
IUSE=""
-
-each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- epatch "${FILESDIR}/${PN}-6.5.1-ruby18-failing-tests.patch"
- ;;
- *)
- ;;
- esac
-}